POJ3259:Wormholes解题报告

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 59121 Accepted: 22111

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

 

NO YES



题目大意:

        /*给予一张有负边的图,现在询问图中是否存在负环,road是双向边,wormhole为负边;*/

        

        起初看题解用floyd,(明明他们都过了的说,大概是脸比较黑);
        放弃floyd,使用spfa,,,
        
        上代码:

#include <cstring>
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <queue>
#define N 6000          //起初写笑了WA *1
#define inf 0x3f3f3f3f
using namespace std;
struct node {
    int to;
    int next;
    int value;
};
class solve{
    node edge[N];
    int n;
    int cnt,head[505];
    int dis[505];
    int num[505];
    bool inque[505];
    void add(int u,int v,int dis){
        edge[cnt].to = v;
        edge[cnt].value=dis;
        edge[cnt].next = head[u];
        head[u] = cnt++;
    }
public:
    bool init(){
        int nr,nw,u,v,d;
        if(scanf("%d %d %d",&n,&nr,&nw)!=3)return false;
        memset(head,-1, sizeof(head));
        cnt = 0;
        for(int i = 0 ; i < nr ; ++i){
            scanf("%d %d %d",&u,&v,&d);
            add(u,v,d);
            add(v,u,d);
        }
        for(int i = 0 ; i < nw ; ++i){
            scanf("%d %d %d",&u,&v,&d);
            add(u,v,-d);
        }
        return true;
    }
    bool deal(){
        return spfa();
    }
    bool spfa(){
        queue<int>que;
        que.push(1);
        memset(dis,inf, sizeof(dis));
        memset(inque,0, sizeof(inque));
        memset(num,0, sizeof(num));
        dis[1] = 0;
        inque[1] = true;
        num[1]++;
        int v,tmp;
        while (!que.empty()){
            v = que.front();
            que.pop();
           // cout<<v<<endl;
            inque[v] = false;
            for(int i = head[v];i!=-1;i = edge[i].next){
                tmp = edge[i].to;
                if(dis[v]+edge[i].value<dis[tmp]){
                    dis[tmp] = dis[v]+edge[i].value;
                    if(!inque[tmp]) {
                        que.push(tmp);
                        inque[tmp] = true;
                        num[tmp]++;
                        if(num[tmp]>n)return true;
                    }
                }
            }
        }
        return false;
    }
};
solve ss;
int main(){
    int T;
    cin>>T;
    while (T--){
        ss.init();
        if(ss.deal())cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值