带负权的最短路bellman_ford——POJ 3259 Wormholes题解

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

解题思路
正权最短路用dij是使用的数组,这里因为是带负权的,所以使用结构体,自定义一个。然后以每个节点为根节点遍历,然后判断是否有负权。犯低级错误,数组下标边界问题没搞对了,错了n发

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
#define inf 1000000
int n, m1, m2,flag = 0;
int num = 0, dis[10010];
struct node
{
	int x,y,cnt;
}road[10000];

int bellman_ford()
{
	memset(dis, inf, sizeof(dis));
	dis[road[0].x] = 0;
	for(int i = 1; i < n; i++)
	{
		for(int j = 0; j < num; j++)
		{
			if(dis[road[j].y] > dis[road[j].x] + road[j].cnt)
				dis[road[j].y] = dis[road[j].x] + road[j].cnt;
		}
	}
	for(int i = 0; i < num ; i++)
		if(dis[road[i].y] > dis[road[i].x] + road[i].cnt)
			flag = 1;
	return flag;
}

int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		flag = 0;
		num = 0;
		memset(road,0,sizeof(road));
		scanf("%d%d%d", &n, &m1, &m2);
		for(int i = 0; i < m1; i++)
		{
			scanf("%d%d%d", &road[num].x, &road[num].y, &road[num].cnt);
			num++;
			road[num].x = road[num-1].y;
			road[num].y = road[num-1].x;
			road[num].cnt = road[num-1].cnt;
			num++;
			 
		}
		for(int i = 0; i < m2; i++)
		{
			scanf("%d%d%d", &road[num].x, &road[num].y, &road[num].cnt);
			road[num].cnt = -road[num].cnt;
			num++;
		}
		if(!bellman_ford())
			printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值