Euclid's Game (博弈)

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12
15 24
0 0
Sample Output
Stan wins
Ollie wins

题意:两个数中较大的数取余较小的数(辗转相除的过程)直到其中一个数为0 时结束,注意:每次的选择都是最完美的选择。

假设两数分别为a , b;通过交换使得a 一直大于b;

分三种情况:

1,a 是 b 的倍数 即a%b = 0 时 ,Stan 先开始 则 Stan必胜。

2.b < a < 2*b时 ,必须通过一步一步来得出谁胜谁负 , 因此在每进行一步时可以用flag = !flag 来确定最后谁胜谁负 , 或用ans++通过判断ans的奇偶来判断,最终得到答案。

3.a >= 2*b时 , 那么Stan可以通过选择来使自己胜 .

	32 7-----S-------1
		
	25 7----O-------2

        11 7-----S-----3

        4 7-----O------4

        4 3-----S-------5

        1 3----O------6

        1 0------S-------7

如上:Stan 可以直接跳到第三步 , 然后一步一步的向下进行最终胜利 ,即只要a>2*b时 , Stan就可以拥有两种选择 , 可以奇数或偶数倍的跳到某一步使对方没有选择权 。

以下是代码:

#include <stdio.h>
#include <iostream>
using namespace std;
int main()
{
	int n , m;
	while(~scanf("%d %d" , &n , &m) && (n + m))
	{
			if(n < m)
			{
				swap(n , m);
			}
			int flag = 0;
		while(m)
		{
				if(n % m == 0 || n/m >= 2)
				{
					break;
				}
				n = n - m;
			if(n < m)
			{
				swap(n , m);
			}
						flag = !flag;
		}
			if(!flag)
					{
						cout << "Stan wins" << endl;
					
					}
					else
					{
						cout <<"Ollie wins" << endl;
				
					}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值