HDU1013 Digital Roots(数根公式)

题目:HDU1013

 

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 93380    Accepted Submission(s): 29125

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24 39 0

Sample Output

6 3

 

方法一:

以字符串形式输入一个数。将其每一位转变成整数加到一个新数上,然后新数的各个位不断相加,直至变为小于10的正整数。

代码:

#include <iostream>
#include <string>
using namespace std;

int main()
{
	string num;
	int Intnum, single;
	while (cin >> num)
	{
		if (num[0] == '0')
			break;
		Intnum = 0;
		single = 0;
		int length = num.size();
		for (int i = 0; i < length; i++)
			Intnum += num[i] - '0';
			
		while (Intnum > 0)
		{
			single += Intnum % 10;
			Intnum /= 10;
			if (Intnum == 0 && single >= 10)
			{
				Intnum = single;
				single = 0;
			}
		}
		cout << single << endl;
	}
	
	return 0;
}

 

方法二:(记住结论)

利用数论中的数根结论,Digital Roots(数根) = (sum - 1) % 9 + 1.   (数根公式推导)

其实这个式子的真正意义就是对9取余,只不过是如果9对9取余,正常结果应该是0,但是这里要输出的是9,所以用那个式子来写就免得专门判断是不是0了。

代码:

#include <iostream>
#include <string>
using namespace std;
 
 
int main()
{
    string num;
    while(cin >> num)
    {
        if(num[0]=='0')
            break;
        int sum = 0;
        for (int i = 0; i < num.size(); i++)
           sum += num[i] - '0';

        cout << (sum - 1) % 9 + 1 << endl;
    }
    
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

CarreLiu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值