HDU_1013 Digital roots

该博客介绍了HDU 1013问题,即数字根的计算方法。数字根是通过将正整数的各位数字相加,如果结果仍为多位数,则继续此过程,直到得到一个单一的数字。输入文件包含一系列正整数,以0结束。输出是每个数字的数字根。博客提到了两种求解数字根的方法:一是对每位数字求和并取9的余数;二是求和后减去1,对9取余再加1。
摘要由CSDN通过智能技术生成

Digital Roots HDU - 1013
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
Output
For each integer in the input, output its digital root on a separate line of the output.
Sample Input

24
39
0

Sample Output

6
3

 #include <iostream>

using namespace std;

int main(){
	string s;
	
	while(cin>>s){
		if(s=="0")
			break; 
		int sum=0;
		int len=s.length();
		for(int i=0;i<len;i++){
			sum+=s[i]-'0';
			//if(sum>9)
			sum=sum%1+sum/10;
		}
		cout<<(sum-1)%9+1<<endl;
		//cou<<sum<<endl;
	}
	return 0;
}

数论相关内容
这个是余九法求数根,如果数字是0则它的数根就是0;
否则直接把这个数的每个位上的数字都加起来,对 9 取余,如果结果为 0 ,那么结果是 9,否则就是求得的数值。
或者,把每一位数字的和加起来 减去 1,对 9 取余之后 ,再加 1,得到的也是正确答案!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值