hdu1010Tempter of the Bone

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
 
 
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0

Sample Output
 
  
NO

YES


题目大意:给出n*m的矩阵,图中
'X': 墙,无法通过
'S': 开始位置
'D': 门,也就是出口
'.':空地,可以走的路径

对于给定的时间t,必须在第t秒到达门,走过的路不可重复。
也就是第t步到达。

正常思路一般的深度搜索或广度搜索(需要考虑出循环的条件),我们采用简单的深度搜索。然后正常地过不了,开始剪枝,本题是奇偶剪枝。
Sample Output
 
  
NO

YES


知道奇偶剪枝之前先知道:

      奇数-偶数=奇数

      奇数-奇数=偶数

      奇数+奇数=偶数

      偶数+偶数=奇数

推论: 奇数作为加数(负号看作加上负数)能改变奇偶性。

   所以两个数之和为奇数,这两个数奇偶性不同;两数之和为偶数,奇偶性相同。


从出发点到达门,最短位置是终点坐标(endx,endy)和开始坐标(stx,sty)经过n次移动到达的长度。

    int best=abs(endx-stx)+abs(endy-sty);

有障碍物时就需要绕行,我们可以自己画图随便找几个点。发现绕行的路径由最短路径平移过去的和多走的部分组成。

不管怎么绕行,多走 的步数一定是对称的,也就是一定为偶数,那么他不改变奇偶性,所以

  只有当剩余的步数与目前位置到终点的最短步数奇偶性相同时,才有可能恰好在t时刻到大门的地方


从任意到达门,最短位置是终点坐标(endx,endy)和此处坐标(x,y)经过n次移动到达的长度。

    int best=abs(endx-x)+abs(endy-y);

设已经走过tim(time)步要求走t步。

若t-tim和best 的奇偶性相同可能为正确的路径。


#include <algorithm>
#include <iostream>
#include <cstring>
using namespace std;
int dis[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
char mp[10][10];
int book[10][10];
int n,m,t,flag;
int edx,edy; 
void dfs(int x,int y,int tim)
{
if(flag)return;
    if(mp[x][y]=='D')
    {
        if(tim==t)
{
        flag=1;
         return;

       
    }
   
   int best=abs(x-edx)+abs(y-edy);
   if(best+tim>t||(t-tim+best)&1)
      return; 
    for(int i=0;i<4;i++)
       {
             int tx=x+dis[i][0];
             int ty=y+dis[i][1];
                if(!book[tx][ty]&&mp[tx][ty]!='X'&&tx>=0&&tx<n&&ty>=0&&ty<m)
                 {
                     book[tx][ty]=1;
                     dfs(tx,ty,tim+1);
                     book[tx][ty]=0;
                   
                 }
              
       }
}
int main()
{
    int tx,ty;
    while(cin>>n>>m>>t)
    {
        flag=0; 
        if(n==0&&m==0&&t==0)
            break;
        getchar(); 
memset(book,0,sizeof(book)); 
        for(int i=0;i<n;i++)
           for(int j=0;j<m;j++)
              {
                    scanf("%c",&mp[i][j]);
                    if(mp[i][j]=='S')
                    {
                        tx=i; ty=j;
                    }
                    if(mp[i][j]=='D')
                    {
                    edx=i; edy=j;

                    if(j==m-1)getchar();
                    
              }
 
              book[tx][ty]=1;
               dfs(tx,ty,0);
               if(flag)
               {
                printf("YES\n"); 
  }else 
                    printf("NO\n");
    }
    return 0;
 } 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wym_king

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值