Starship Troopers(树状dp) hdu1011

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21717    Accepted Submission(s): 5790


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
 
 
5 1050 1040 1040 2065 3070 301 21 32 42 51 120 7-1 -1
Sample Output
 
  
50
7

题意:

第一行给出n个房间和m艘星际战舰的数量.接下来n行第i行描述第i个房间的信息,再接下来n-1行描述两个房间是相通的。

必须从第一个房间开始向后,每20个虫子需要用一艘战舰,不足20(包括0)需要1艘.所以m==0,直接输出0换行continue。

用dp[i][j]记录答案,其中i表示根节点,j表示派出j艘战舰。

从第一个点开始对联通的点v递归,并初始化对应dp[v][z]到dp[v][m]都等于v点的possibility。

递归就标记,不再还原。一直递归到最后一个点,第一次返回后开始第一次动态规划。

 对每个点index和已经去过的点v,是选择以点v为根节点的物品组(可以视为一个物品组)还是不选择,就是看谁更大

    dp[index][j]=max(dp[index][j],dp[index][j-k]+dp[v][k]);

 (j-k表示已经派了k艘战舰,然后收获为dp[v][k],dp[index][j]原本表示派出j艘战舰的收获,但是还没有递归回去,所以暂时为前面初始化的值)

  至于存储数据问题,可以用邻阶矩阵或数组套用,我用的是c++.c++stl功能比较强大,建议了解一下
#include <algorithm>
#include <cstring>
#include <iostream>
#include <vector>
using namespace std;
struct news{
    int bugs;
    int poss;
};
news num[106];
vector<vector<int> > mp;
int book[106],n,m;
int dp[106][106],tot=0;


bool cmp(int a,int b)
{
    return a>b;
}
void dfs(int index)
{
    book[index]=1;
    int z=(num[index].bugs+19)/20;
    for(int i=z;i<=m;i++) dp[index][i]=num[index].poss;
    for(int i=0;i<mp[index].size();i++)
        {
            int v=mp[index][i];
          
            if(book[v])
              continue;
                dfs(v);
                
        for(int j=m;j>=z;j--)//可能的派遣战舰数量,由于这个点本身消耗z,而又必须占据这个点才能到下一个点

            for(int k=1;k<=j-z;k++)//在占领这个点的条件下,可以分配出去的点的数量(总数-z),

                                                 //例如j==m,能分配出去的战舰就是占领这个点后剩下的战舰,也就是只能小于等于m-z;

                  dp[index][j]=max(dp[index][j],dp[index][j-k]+dp[v][k]);
              
        }


    return;
}
int main()
{
    
    while(cin>>n>>m)
    {
        if(n==-1&&m==-1)
        break;
        memset(dp,0,sizeof(dp));
        memset(book,0,sizeof(book));
         mp.resize(100+5,vector<int>(100+5));
        for(int  i=0;i<=n;i++)
             mp[i].clear();
        
        for(int i=1;i<=n;i++)
            {
                cin>>num[i].bugs>>num[i].poss;
            }
        for(int i=0;i<n-1;i++)
           {
                int t1,t2;
                cin>>t1>>t2;
                mp[t1].push_back(t2);
                mp[t2].push_back(t1);
           }
    
    if(m==0)  
        cout<<0<<endl;  
    else  
        {  
        dfs(1);  
        cout<<dp[1][m]<<endl;  
        }  
    }
  return 0;    

Sample Output
 
  
50
7
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

wym_king

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值