1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
  • 多项式可以用数组存储,下表是指数,内容是系数。需要注意的是C++ map也是一种特殊的数组,如果指数的范围过大,可以使用map来存储多项式。计算结果放在数组中。
#include<cstdio>
#include<map>
using namespace std;
int main()
{
    int K1;
    scanf("%d", &K1);
    double Poly[2020] = {0};//结果存储,注意指数可能是1000 + 1000,一定要初始化。
    map<int, double> Poly1;//第一个多项式
    int ex;
    double co;
    for(int i = 1; i <= K1; i++)
    {
        scanf("%d%lf", &ex, &co);
        Poly1[ex] = co;
    }
    int K2;
    scanf("%d", &K2);
    for(int j = 1; j <= K2; j++)
    {
        scanf("%d%lf", &ex, &co);
        for(map<int, double>::iterator iter = Poly1.begin(); iter != Poly1.end(); iter++)
        {//可以输入一个值就直接运算出结果
            int label = (iter -> first) + ex;
            double content = (iter -> second) * co;
            Poly[label] += content;
        }
    }
    int Count = 0;
    for(int m = 0; m < 2020; m++)
    {
        if(Poly[m] != 0.0)
            Count++;
    }
    printf("%d", Count);
    for(int n = 2019; n >= 0; n--)
    {
        if(Poly[n] != 0.0)
            printf(" %d %.1f", n, Poly[n]);
    }
    return 0;
}
  •  多项式的加法见PAT 1002

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值