NYOJ 5题------Binary String Matching

Binary String Matching

时间限制:3000 ms  |  内存限制:65535 KB

难度:3

描述

Given two strings A and B, whose alphabet consist only ‘0’ and ‘1’. Your task is only to tell how many times does A appear as a substring of B? For example, the text string B is ‘1001110110’ while the pattern string A is ‘11’, you should output 3, because the pattern A appeared at the posit

输入

The first line consist only one integer N, indicates N cases follows. In each case, there are two lines, the first line gives the string A, length (A) <= 10, and the second line gives the string B, length (B) <= 1000. And it is guaranteed that B is always longer than A.

输出

For each case, output a single line consist a single integer, tells how many times do B appears as a substring of A.

样例输入

3
11
1001110110
101
110010010010001
1010
110100010101011 

样例输出

3
0
3 

来源

网络

上传者

naonao

题目链接:http://acm.nyist.edu.cn/JudgeOnline/problem.php?pid=5

题目大意就是数组A和B,A在B中出现几次;

题目详细翻译可自行百度

#include <stdio.h>
#include <string.h>
int main()
{
    char a[20],b[1010];
    int n,x,y,q,s,t,p;
    scanf("%d",&n);
    for(int o=0;o<n;o++)
    {

        scanf("%s%s",a,b);
        getchar(); //消除回车
        p=0;    
        s=strlen(a);    
        t=strlen(b);    //检测a,b两个字符串的长度
        for(int i=0;i<t;i++)    //从b[0]开始循环
        {
            x=i;                //把i的值赋给x 防止下面++导致上面循环出错
            q=0;                
            for(int j=0;j<s;j++)  //例如: 11           11           11           11        ......  如此上下比较
            {                     //      1001110110  1001110110  1001110110  1001110110      
                y=j;                
                if(b[x]==a[y])      
                    q++;        
                x++;                //x++ 使a、b上下对照
            }                       //这里循环令字符串a中的元素分别与b中的s个连续元素比较如果有相等就q++
            if(q==s)                //如果q==t那么说明上面和下面比较每次都相同 也就是说a在b中出现一次 于是p++
                p++;
        }
        printf("%d\n",p);        
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值