D - Sticks HDU - 1455 回溯,剪枝

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
InputThe input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
OutputThe output file contains the smallest possible length of original sticks, one per line.
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5
第一道正正宗宗的剪枝题目,磨了三天看别人博客过了啊哈哈,的确剪枝的思路比我的厉害很多。

#include"iostream"
#include"algorithm"
#include"cstring"
using namespace std;
int gen,len,aim,xx[70],vst[70],sum,n;
int cmp(int x,int y)
{
	return x>y;
}

int dfs(int cnt,int lenn,int pos)
{
	if(cnt==gen)
	{
		return 1;
	}
	if(lenn==aim)
	{
		return dfs(cnt+1,0,0);
	}
	for(int i = pos;i < n;i ++)
	{
		if(!vst[i] && xx[i]+lenn <= aim)
		{
			vst[i]=1;
			if(dfs(cnt,lenn+xx[i],i+1))
			{
				return 1;
			} 
			vst[i]=0;
			if(lenn == 0)
			{
				return 0;
			}
			while(i + 1 < n && xx[i]==xx[i+1])
			{
				i++;
			}
		}
	}
	return 0;
}


void init()
{
	sum = 0;
	for(int i = 0;i < n;i ++)
	{
		cin >> xx[i];
		sum += xx[i];
	}
	sort(xx,xx+n,cmp);
}
void solve()
{
	int ans=0;
	for(int i = 1;i <= sum;i ++)
	{
		memset(vst,0,sizeof(vst));
		if(sum % i != 0)
		{
			continue;
		}	
		aim=i;
		gen=sum/aim;
		if(dfs(0,0,0))
		{
			ans=aim;
			break;
		} 
	} 
	cout<<ans<<endl;
} 
int main()
{
	while(cin >> n && n)
	{
		init();
		solve();
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值