D - Sticks POJ - 1011 (深搜 剪枝)

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.
Input
The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.
Output
The output should contains the smallest possible length of original sticks, one per line.
Sample Input
9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0
Sample Output
6
5

import java.util.Arrays;
import java.util.*;

public class Main {
	static int n,sum,t;
	static int []a = new int [100];
	static int []b = new int [100];
	static int []vis = new int [100];
	
	static Boolean dfs(int len,int m){
		if(m==0&&len==0)	return true;
		if(m!=0&&len==0)	len=t;    //当m!=0但是len=0时,说明已经成功拼成一块木板,继续拼接此长度的木板
		for(int i=1;i<=n;++i){
			if(vis[i]==1)	continue;
			if(a[i]>len)	continue;	
			vis[i] = 1;
			if(dfs(len-a[i],m-1))return true;
			else{
				vis[i] = 0;
				if(len==t||len==a[i]) return false;
				/*当走到这一步时说明之前的dfs返回的应该为false,len=t时,当前状态为dfs(0,m),如果当len=4,
				 木板分别为3,2,当3+2不合适时,2+3也一定不合适,因此,不需要再尝试了,因此return false
				 当len=a[i]时,同样会到达dfs(0,m-1)的状态,因此也无需继续判断*/
			}
		}
		return false;
	}
	
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		while(cin.hasNext()){
			n = cin.nextInt();
			if(n==0)	break;
			sum = 0;
			for(int i=1;i<=n;++i){
				a[i] = cin.nextInt();
				sum += a[i];
			}
			//从大到小排序
			Arrays.sort(a,0,n+1);
			for(int i=1;i<=n;++i)	b[n-i+1] = a[i];
			for(int i=1;i<=n;++i)	a[i] = b[i];
	
			int len;
			for(len=a[1];len<=sum/2;++len){
				if(sum%len!=0)	continue;
				Arrays.fill(vis, 0);
				t=len; //标记当前所尝试的长度
				if(dfs(len,n)){
					System.out.println(len);
					break;
				}
			}
			if(len>sum/2)	System.out.println(sum);
		}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值