HDU 1690 Bus System(long long类型,w数组初始化要很大,Floyed最短路)

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9769    Accepted Submission(s): 2663


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
 
 
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
 
 
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 
        题意:给出n个点,每个点有一个x轴坐标值,同时给出距离与花费的关系,求从起始点到目标点的最小花费(注意距离>D4则不可能到达,或者说......不能买多张票)

        题目挺简单,注意数据类型,和初始化值,另外以后尽量不要用0x7f了,很多情况下不好用。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const long long INF=1e18;
long long w[110][110];
long long a[110];
long long L1,L2,L3,L4,C1,C2,C3,C4;
long long fcost(long long x)
{
    if(x>0&&x<=L1)return C1;
    else if(x<=L2)return C2;
    else if(x<=L3)return C3;
    else if(x<=L4)return C4;
    else return INF;
}
int main()
{
    long long t,k=1;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld%lld%lld%lld%lld%lld%lld",&L1,&L2,&L3,&L4,&C1,&C2,&C3,&C4);
        long long int n,m;
        scanf("%lld%lld",&n,&m);
        for(int i=0;i<=n;++i)a[i]=0;
        for(int i=0;i<=n;++i)
            for(int j=0;j<=n;++j)w[i][j]=INF;
        for(int i=1;i<=n;++i)scanf("%lld",&a[i]);
        for(int i=1;i<=n;++i)
        {
            w[i][i]=0;
            for(int j=i+1;j<=n;++j)w[i][j]=w[j][i]=fcost(abs(a[i]-a[j]));
        }
        for(int k=1;k<=n;++k)
            for(int i=1;i<=n;++i)
                for(int j=1;j<=n;++j)
                {
                    //if(w[i][k]!=INF&&w[k][j]!=INF)
                        w[i][j]=min(w[i][j],w[i][k]+w[k][j]);
                }
        printf("Case %lld:\n",k++);
        while(m--)
        {
            long long int x,y;
            scanf("%lld%lld",&x,&y);
            if(w[x][y]!=INF)printf("The minimum cost between station %lld and station %lld is %lld.\n",x,y,w[x][y]);
            else printf("Station %lld and station %lld are not attainable.\n",x,y);
        }
    }
    return 0;
}


The end;



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值