Fence Repair POJ 3253(逆向思维+优先队列实现)

Fence Repair

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 60098 Accepted: 19842

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source

USACO 2006 November Gold

 

==============================

题目大意:

给定一组木板的长度,问怎样切割一整块木板(切割n-1次)能得到所需木板组合且花费最小,整块木板长度等于木板组的长度之和。

思路:

容易想到为贪心,刚开始错误思路是每次从木板组中去掉最长的那一块,以此来保证每次切割的都是最小的,但是这样不能保证最优解(切割时分为的两部分不一定必须包含木块组中的长度),例如如下测试数据:

5

1 2 3 4 5

错误思路是将长度为15的木板首先分为10、5,但如果算一下就会发现,分为6、9更好。

所以正确思路应当是逆向考虑,将切木块变为合并木板,每次合并最短的两块木板,最终得到最优解。

 

PS:该题数据可能会溢出,统计和的变量和表示木块组长度的变量最好定义为long long 型。

 

错误代码:

#include<iostream>
#include<queue>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        priority_queue < int,vector<int>,less<int> > Q;
        int tot=0,ans=0;
        for(int i=1;i<=n;++i)
        {
            int x;
            cin>>x;
            tot+=x;
            Q.push(x);
        }
        while(Q.size()>1)
        {
            int p=Q.top();
            Q.pop();
            ans+=tot;
            tot-=p;

        }
        cout<<ans<<endl;
    }
    return 0;
}

 

AC代码:

#include<iostream>
#include<queue>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        priority_queue<int,vector<int>,greater<int> > Q;
        long long x;
        for(int i=1;i<=n;++i)
        {
            cin>>x;
            Q.push(x);
        }
        long long ans=0;
        while(Q.size()>1)
        {
            int p=Q.top();
            Q.pop();
            int q=Q.top();
            Q.pop();
            ans+=p+q;
            Q.push(p+q);
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

 

The end;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值