次最小生成树模板

The Unique MST

POJ - 1679

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn=105;
int Map[maxn][maxn], dis[maxn], vis[maxn];
int used[maxn][maxn];//判断该边是否加入最小生成树
int pre[maxn];
int Max[maxn][maxn];//表示最小生成树中i到j的最大边权
int n, m;
int prime()
{
     memset(vis, 0, sizeof(vis));
     memset(used, 0, sizeof(used));
     for(int i=1;i<=n;i++)
     {
        dis[i]=Map[1][i];
        pre[i]=1;
     }
     int sum=0;
     vis[1]=1;
     for(int i=1;i<n;i++)
     {
         int minn=inf, k=1;
         for(int j=1;j<=n;j++)
         {
             if(vis[j]==0&&minn>dis[j])
             {
                minn=dis[j];
                k=j;
             }
         }
         if(minn==inf)
         {
            return -1;
         }
         vis[k]=1;
         sum+=minn;
         used[k][pre[k]]=used[pre[k]][k]=1;
         for(int j=1;j<=n;j++)
         {
              if(vis[j])
              {
                  Max[j][k]=Max[k][j]=max(dis[k], Max[j][pre[k]]);  //****
              }
              if(vis[j]==0&&dis[j]>Map[j][k])
              {
                   dis[j]=Map[j][k];
                   pre[j]=k;
              }
         }
     }
     return sum;//sum是最小生成树的权值之和
}
int smst(int n, int minn) //minn是最小生成树的权值之和
{
     int ans=inf;
     for(int i=1;i<=n;i++)
     {
        for(int j=i+1;j<=n;j++)
        {
            if(Map[i][j]!=inf&&!used[i][j])
            {
                ans=min(ans, minn+Map[i][j]-Max[i][j]);
            }
        }
     }
     if(ans==inf)
     return -1;
     else
     return ans;
}
int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
         scanf("%d%d", &n, &m);
         for(int i=1;i<=n;i++)
         {
            for(int j=1;j<=n;j++)
            {
              if(i==j)
              Map[i][j]=0;
              else
              Map[i][j]=inf;
            }
         }
         int u, v, w;
         for(int i=0;i<m;i++)
         {
             scanf("%d%d%d", &u, &v, &w);
             Map[u][v]=Map[v][u]=w;
         }
         int ans=prime();
         if(ans==-1)
         {
            printf("Not Unique!\n");
            continue;
         }
         if(ans==smst(n, ans))
         printf("Not Unique!\n");
         else
         printf("%d\n", ans);
    }
    return 0;
}

 

代码来源kuangbin。

//============================================================================
// Name        : POJ.cpp
// Author      : 
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

/*
 * 次小生成树
 * 求最小生成树时,用数组Max[i][j]来表示MST中i到j最大边权
 * 求完后,直接枚举所有不在MST中的边,替换掉最大边权的边,更新答案
 * 点的编号从0开始
 */
const int MAXN=110;
const int INF=0x3f3f3f3f;
bool vis[MAXN];
int lowc[MAXN];
int pre[MAXN];
int Max[MAXN][MAXN];//Max[i][j]表示在最小生成树中从i到j的路径中的最大边权
bool used[MAXN][MAXN];
int Prim(int cost[][MAXN],int n)
{
    int ans=0;
    memset(vis,false,sizeof(vis));
    memset(Max,0,sizeof(Max));
    memset(used,false,sizeof(used));
    vis[0]=true;
    pre[0]=-1;
    for(int i=1;i<n;i++)
    {
        lowc[i]=cost[0][i];
        pre[i]=0;
    }
    lowc[0]=0;
    for(int i=1;i<n;i++)
    {
        int minc=INF;
        int p=-1;
        for(int j=0;j<n;j++)
            if(!vis[j]&&minc>lowc[j])
            {
                minc=lowc[j];
                p=j;
            }
        if(minc==INF)return -1;
        ans+=minc;
        vis[p]=true;
        used[p][pre[p]]=used[pre[p]][p]=true;
        for(int j=0;j<n;j++)
        {
            if(vis[j])Max[j][p]=Max[p][j]=max(Max[j][pre[p]],lowc[p]);
            if(!vis[j]&&lowc[j]>cost[p][j])
            {
                lowc[j]=cost[p][j];
                pre[j]=p;
            }
        }
    }
    return ans;
}
int ans;
int smst(int cost[][MAXN],int n)
{
    int Min=INF;
    for(int i=0;i<n;i++)
        for(int j=i+1;j<n;j++)
            if(cost[i][j]!=INF && !used[i][j])
            {
                Min=min(Min,ans+cost[i][j]-Max[i][j]);
            }
    if(Min==INF)return -1;//不存在
    return Min;
}
int cost[MAXN][MAXN];
int main()
{
    int T;
    int n,m;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        int u,v,w;
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
            {
                if(i==j)cost[i][j]=0;
                else cost[i][j]=INF;
            }
        while(m--)
        {
            scanf("%d%d%d",&u,&v,&w);
            u--;v--;
            cost[u][v]=cost[v][u]=w;
        }
        ans=Prim(cost,n);
        if(ans==-1)
        {
            printf("Not Unique!\n");
            continue;
        }
        if(ans==smst(cost,n))printf("Not Unique!\n");
        else printf("%d\n",ans);
    }
    return 0;
}

转载一个  有一个不错的题

https://blog.csdn.net/qq_27437781/article/details/70821413

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值