L2_006.树的遍历

L2_006.树的遍历

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:
输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:
在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

  • 输入样例:
    7
    2 3 1 5 7 6 4
    1 2 3 4 5 6 7
  • 输出样例:
    4 1 6 3 5 7 2
  • 思路:用一个struct数组模拟二叉树,然后用dfs找到根,存进数字的l,r里
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
const int maxn = 50;
int mid[maxn], be[maxn];
struct node {
	int l, r;
}a[maxn];

int build(int la, int ra, int lb, int rb)//la,ra表示中序遍历 lb,rb表示后序遍历
{
	if (la>ra)
		return 0;
	int rt = be[rb], p1, p2;//取后序遍历的最后一个点为根
	p1 = la;
	while (mid[p1] != rt)	p1++;//在中序遍历中找到根节点
	p2 = p1 - la;//是左子树的长度
	a[rt].l = build(la, p1 - 1, lb, lb + p2 - 1);//左,把左子树从根的左边分出来,lb->lb+p2-1是左子树,-1是排除掉根
	a[rt].r = build(p1 + 1, ra, lb + p2, rb - 1);//右,同上
	return rt;
}
void bfs(int x)//层序遍历
{
	queue<int>q;
	vector<int>v;
	q.push(x);
	while (!q.empty())
	{
		int w = q.front();
		q.pop();
		if (w == 0)
			break;
		v.push_back(w);
		if (a[w].l != 0)
			q.push(a[w].l);
		if (a[w].r != 0)
			q.push(a[w].r);
	}
	int len = v.size();
	for (int i = 0; i<len; i++)
		printf("%d%c", v[i], i == len - 1 ? '\n' : ' ');
	return;
}
int main()
{
	int n, i;
	cin >> n;
	for (i = 0; i<n; i++) scanf("%d", &be[i]);
	for (i = 0; i<n; i++) scanf("%d", &mid[i]);
	build(0, n - 1, 0, n - 1);
	int root = be[n - 1];
	bfs(root);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值