甲级1103 Integer Factorization (dfs + 剪枝)

1103 Integer Factorization (30 分)

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n[1]^P + ... n[K]^P

where n[i] (i = 1, ..., K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12​2​​+4​2​​+2​2​​+2​2​​+1​2​​, or 11​2​​+6​2​​+2​2​​+2​2​​+2​2​​, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a​1​​,a​2​​,⋯,a​K​​ } is said to be larger than { b​1​​,b​2​​,⋯,b​K​​ } if there exists 1≤L≤K such that a​i​​=b​i​​ for i<L and a​L​​>b​L​​.

If there is no solution, simple output Impossible.

Sample Input 1:

169 5 2

Sample Output 1:

169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2

Sample Input 2:

169 167 3

Sample Output 2:

Impossible

本题思路 :

给定 n的值范围   用 k (k<n)个 数的p次方相加得到出 n  并输出这个式子(式子中的系数从大到小排列)

 

运用dfs 并 剪枝:

循环k次找到对应的5个式子, 但是当n的值很大,一个for循环的范围(1-n)就很大,因此需要剪枝(优化一些不必要判断的条件)当 k 的 p次方 > n时就不需要继续循环, 因此将 小于 n的所有系数次方放入 vector<int> v 中

void init(){
	int temp = 0, i = 1;
	while(temp <= n){         // 系数 的p次方 范围是可以与n相等的 
		v.push_back(temp);
		temp = pow(i, p);
		i++;
	}
}

c++的问题:

1. 两个容器相等 path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素

2.vector resize(),reverse, ()的区别

//https://blog.csdn.net/zjm750617105/article/details/62426843?utm_source=blogxgwz5

使用for循环 两个测试点超时 用while循环 并 在dfs局部处理 (n的范围)

void dfs(int tempk, int sum,int sumfactor){
	if(tempk == k){
		if(sum == n && sumfactor > maxfactor){
			path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素复制给vect1, vect1和vect2的类型
			maxfactor = sumfactor;
		}
		return;
	}
	for(int i = v.size()-1; i >= 1; i--){ //i代表式子中系数的具体值  (超时)
		if(sum + v[i] > n){
			continue;
		}
		pre[tempk] = i;  //直接通过此时第K个 式子进行覆盖 并不需要在容器中一进一出 
		dfs(tempk + 1, sum + v[i], sumfactor + i);
		if(i == 1) return 
	}
}

具体代码:

#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
//https://blog.csdn.net/zjm750617105/article/details/62426843?utm_source=blogxgwz5
using namespace std;
vector<int> pre, path, v;
int n, k, p, maxfactor = -1, tempk = 0, sum, sumfactor;
void init(){
	int temp = 0, i = 1;
	while(temp <= n){         // 系数 的p次方 范围是可以与n相等的 
		v.push_back(temp);
		temp = pow(i, p);
		i++;
	}
}

void dfs(int index, int tempk, int sum,int sumfactor){
	if(tempk == k){
		if(sum == n && sumfactor > maxfactor){
			path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素复制给vect1, vect1和vect2的类型
			maxfactor = sumfactor;
		}
		return;
	}
	while(index >= 1) {
        if (sum + v[index] <= n) {
            pre[tempk] = index;
            dfs(index, tempk + 1, sum + v[index], sumfactor + index);
        }
        if (index == 1) return;
        index--;
    }
}
//bool cmp(int a, int b){
//	return a > b; //非升序 
//}
int main(){
	scanf("%d%d%d", &n, &k, &p);
	//path.reserve(k);//
	//pre.reserve(k);	//将pre的k个长度赋值为空
	pre.resize(k);//将pre的k个长度赋值为0 io 
	init();
//	dfs(tempk, sum, sumfactor);
	dfs(v.size()-1, tempk, sum, sumfactor);
	if(maxfactor == -1){
		printf("Impossible");
		return 0;	
	} 
	printf("%d = ", n);
//	sort(path.begin(), path.end(), cmp);
	for(int i = 0; i < k; i++){
		if(i != 0)
			printf(" + ");
		printf("%d^%d", path[i], p);
	} 
	return 0;
}

 

在探索智慧旅游的新纪元中,一个集科技、创新与服务于一体的整体解决方案正悄然改变着我们的旅行方式。智慧旅游,作为智慧城市的重要分支,旨在通过新一代信息技术,如云计算、大数据、物联网等,为游客、旅游企业及政府部门提供无缝对接、高效互动的旅游体验与管理模式。这一方案不仅重新定义了旅游行业的服务标准,更开启了旅游业数字化转型的新篇章。 智慧旅游的核心在于“以人为本”,它不仅仅关注技术的革新,更注重游客体验的提升。从游前的行程规划、信息查询,到游中的智能导航、个性化导览,再到游后的心情分享、服务评价,智慧旅游通过构建“一云多屏”的服务平台,让游客在旅游的全过程中都能享受到便捷、个性化的服务。例如,游客可以通过手机APP轻松定制专属行程,利用智能语音导览深入了解景点背后的故事,甚至通过三维GIS地图实现虚拟漫游,提前感受目的地的魅力。这些创新服务不仅增强了游客的参与感和满意度,也让旅游变得更加智能化、趣味化。 此外,智慧旅游还为旅游企业和政府部门带来了前所未有的管理变革。通过大数据分析,旅游企业能够精准把握市场动态,实现旅游产品的精准营销和个性化推荐,从而提升市场竞争力。而政府部门则能利用智慧旅游平台实现对旅游资源的科学规划和精细管理,提高监管效率和质量。例如,通过实时监控和数据分析,政府可以迅速应对旅游高峰期的客流压力,有效预防景区超载,保障游客安全。同时,智慧旅游还促进了跨行业、跨部门的数据共享与协同合作,为旅游业的可持续发展奠定了坚实基础。总之,智慧旅游以其独特的魅力和无限潜力,正引领着旅游业迈向一个更加智慧、便捷、高效的新时代。
内容概要:本文详细介绍了大模型的发展现状与未来趋势,尤其聚焦于DeepSeek这一创新应用。文章首先回顾了人工智能的定义、分类及其发展历程,指出从摩尔定律到知识密度提升的转变,强调了大模型知识密度的重要性。随后,文章深入探讨了DeepSeek的发展路径及其核心价值,包括其推理模型、思维链技术的应用及局限性。此外,文章展示了DeepSeek在多个行业的应用场景,如智能客服、医疗、金融等,并分析了DeepSeek如何赋能个人发展,具体体现在公文写作、文档处理、知识搜索、论文写作等方面。最后,文章展望了大模型的发展趋势,如通用大模型与垂域大模型的协同发展,以及本地部署小模型成为主流应用渠道的趋势。 适合人群:对人工智能和大模型技术感兴趣的从业者、研究人员及希望利用DeepSeek提升工作效率的个人用户。 使用场景及目标:①了解大模型技术的最新进展和发展趋势;②掌握DeepSeek在不同领域的具体应用场景和操作方法;③学习如何通过DeepSeek提升个人在公文写作、文档处理、知识搜索、论文写作等方面的工作效率;④探索大模型在特定行业的应用潜力,如医疗、金融等领域。 其他说明:本文不仅提供了理论知识,还结合实际案例,详细介绍了DeepSeek在各个场景下的应用方式,帮助读者更好地理解和应用大模型技术。同时,文章也指出了当前大模型技术面临的挑战,如模型的局限性和数据安全问题,鼓励读者关注技术的持续改进和发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值