1103 Integer Factorization (30 分)
The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format:
N = n[1]^P + ... n[K]^P
where n[i]
(i
= 1, ..., K
) is the i
-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122+42+22+22+12, or 112+62+22+22+22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1,a2,⋯,aK } is said to be larger than { b1,b2,⋯,bK } if there exists 1≤L≤K such that ai=bi for i<L and aL>bL.
If there is no solution, simple output Impossible
.
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
本题思路 :
给定 n的值范围 用 k (k<n)个 数的p次方相加得到出 n 并输出这个式子(式子中的系数从大到小排列)
运用dfs 并 剪枝:
循环k次找到对应的5个式子, 但是当n的值很大,一个for循环的范围(1-n)就很大,因此需要剪枝(优化一些不必要判断的条件)当 k 的 p次方 > n时就不需要继续循环, 因此将 小于 n的所有系数次方放入 vector<int> v 中
void init(){
int temp = 0, i = 1;
while(temp <= n){ // 系数 的p次方 范围是可以与n相等的
v.push_back(temp);
temp = pow(i, p);
i++;
}
}
c++的问题:
1. 两个容器相等 path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素
2.vector resize(),reverse, ()的区别
//https://blog.csdn.net/zjm750617105/article/details/62426843?utm_source=blogxgwz5
使用for循环 两个测试点超时 用while循环 并 在dfs局部处理 (n的范围)
void dfs(int tempk, int sum,int sumfactor){
if(tempk == k){
if(sum == n && sumfactor > maxfactor){
path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素复制给vect1, vect1和vect2的类型
maxfactor = sumfactor;
}
return;
}
for(int i = v.size()-1; i >= 1; i--){ //i代表式子中系数的具体值 (超时)
if(sum + v[i] > n){
continue;
}
pre[tempk] = i; //直接通过此时第K个 式子进行覆盖 并不需要在容器中一进一出
dfs(tempk + 1, sum + v[i], sumfactor + i);
if(i == 1) return
}
}
具体代码:
#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
//https://blog.csdn.net/zjm750617105/article/details/62426843?utm_source=blogxgwz5
using namespace std;
vector<int> pre, path, v;
int n, k, p, maxfactor = -1, tempk = 0, sum, sumfactor;
void init(){
int temp = 0, i = 1;
while(temp <= n){ // 系数 的p次方 范围是可以与n相等的
v.push_back(temp);
temp = pow(i, p);
i++;
}
}
void dfs(int index, int tempk, int sum,int sumfactor){
if(tempk == k){
if(sum == n && sumfactor > maxfactor){
path = pre;//path1=pre, 先是删除vect的所有元素, 然后将vect2所有的元素复制给vect1, vect1和vect2的类型
maxfactor = sumfactor;
}
return;
}
while(index >= 1) {
if (sum + v[index] <= n) {
pre[tempk] = index;
dfs(index, tempk + 1, sum + v[index], sumfactor + index);
}
if (index == 1) return;
index--;
}
}
//bool cmp(int a, int b){
// return a > b; //非升序
//}
int main(){
scanf("%d%d%d", &n, &k, &p);
//path.reserve(k);//
//pre.reserve(k); //将pre的k个长度赋值为空
pre.resize(k);//将pre的k个长度赋值为0 io
init();
// dfs(tempk, sum, sumfactor);
dfs(v.size()-1, tempk, sum, sumfactor);
if(maxfactor == -1){
printf("Impossible");
return 0;
}
printf("%d = ", n);
// sort(path.begin(), path.end(), cmp);
for(int i = 0; i < k; i++){
if(i != 0)
printf(" + ");
printf("%d^%d", path[i], p);
}
return 0;
}