pat甲级 1032Sharing(链表)

1032 Sharing (25 分)

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

fig.jpg

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5​​), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

suffix :后缀

/**
 %c是会读入回车和空格的 因此想要获取输入zi scanf("%d %c %d", &a, &b, &c);
本题题意 :是找到给定一个链表存放2个英语单词(一个结点对应一个字母),然后给定两个个字母的起始结点的起始地址
当两个字母中存在相同结点的地址, 则输出这个地址,否则输出-1
本题思路:
  1.用非结构体数组存放链表  
  2.通过第一个地址 与 next[i]数组(存放地址为i结点的下一个地址)找到所有存在的点 visit[i]数组 = 1 表示地址为i的结点已经存在
  3.通过第二个地址 与 next[i]数组 找到是否存在相同地址的结点
**/

#include<iostream>
const int maxsize = 1e5 + 5;
int start1, start2, n;
int next[maxsize], visit[maxsize];
char data[maxsize];
int main(){
	scanf("%d%d%d", &start1, &start2, &n);
	int ad;
	for(int i = 0; i < n; i++){
		scanf("%d", &ad);
		scanf(" %c %d", &data[ad], &next[ad]);
	}
	while(start1 != -1){
		visit[start1] = 1;
		start1 = next[start1];
		
	}
	while(start2 != -1){
		if(visit[start2] == 1){
			printf("%05d\n", start2);
			return 0;
		}
		start2 = next[start2];
	}
	printf("-1\n");	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值