【PAT(甲级)】1032 Sharing

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

解题思路:

我自己的思路是定义一个结构来存储node的相关信息,再用map将地址与node关联起来,然后将地址按照先后顺序组装起来(因为按照题目的意思我们找到的后缀不仅仅是字母相同,地址也应该相同,那我的想法就是直接组装地址咯)。最后再从后往前比较地址是否相同,就可以得出答案。

易错点:

1. 测试点3是起始地址为-1的情况;

2. 测试点4是因为求的是后缀,中间有相同的字母是不算的;

3. 测试点5就单纯的是时间问题,可以用set啊,哈希表啊等等方法来帮自己提速。

代码:

#include<bits/stdc++.h>
using namespace std;
string w1,w2;
int N;

typedef struct Node{
	string address;
	string data;
	string next;
};

int main(){
	cin>>w1>>w2>>N;
	
	if(w1=="-1"||w2=="-1"){//测试点3的特殊情况 
		cout<<-1;
		return 0;
	}
	
	map<string,Node> node;

	for(int i=0;i<N;i++){
		string a,b,c;
		cin>>a>>b>>c;
		node[a].address = a;
		node[a].data = b;
		node[a].next = c;
	}
	string word1,word2;
	while(w1!="-1"){
		word1 += node[w1].address;
		w1 = node[w1].next;
	}
	while(w2!="-1"){
		word2 += node[w2].address;
		w2 = node[w2].next;
	}
	
	string til = "-1";
	int flag =1;
	if(word2.size()>word1.size()){//默认设置word1为长一些的字符串
		string t;
		t = word2;
		word2 = word1;
		word1 = t;
	}
	

	int j1=word1.size()-5,j2=word2.size()-5;//从后往前每5个数字为一组进行判断

	for(j1;j2>=0;j1-=5){
		if(j1==word1.size()-5&&word1.substr(j1,5)!=word2.substr(j2,5)){
//当最后一组地址都不相同的时候就说明没有相同的后缀,直接输出-1
			cout<<"-1";
			return 0;
		}
		else if(word1.substr(j1,5)!=word2.substr(j2,5)){
			break;
		}
		j2-=5;
	}
	
	string result; 
	for(int i=j1+5;i<j1+10;i++){
		result+=word1[i];
	}
	cout<<result;
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值