1055 The World's Richest(排序(剪枝))

1055 The World's Richest (25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

/**
本题题意:
        就是给出n个人 和 k个查询条件,接下来n行 包括人名  年龄 他们拥有的钱
    接下来 k个条件包括:
        规定的数量, 以及他们的年龄范围
    输出时 需要 按照 钱的降序, 如果钱相等,就按照年龄的升序 , 年龄相等, 就按照 人名的升序。
本题思路:
     设置一个结构体存放查询条件信息,然后根据查询条件排序即可
     只不过本题需要注意的是, 因为有多组查询条件, 并且最大数值为 10w
     不能将排序写在多组查询条件中, 要将排序写在多组查询条件外,  
     考试时: 规定数量能够剪枝,因为规定是 最多筛选满足条件的出前100人, 根据年龄的范围,经过排序 将 1 - 200岁 的所有前100个人数放入数组valid中
     此时将容器优化为 了 20000 最后一个测试点就不会超时。
**/

未优化代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int maxsize = 1e5 + 5;
struct Node{
	string name;
	int age, wor;
}per[maxsize];
int n, k;
bool cmp(Node a, Node b){
	if(a.wor != b.wor)
		return a.wor > b.wor;
	else if(a.age != b.age)
		return a.age < b.age;
	else if(a.name != b.name)
		return a.name < b.name;
}
int main(){
	string name;
	int age, wor, sum, down, up;
	scanf("%d%d", &n, &k);
	for(int i = 0; i < n; i++){
		cin >> name;
		scanf("%d%d", &age, &wor);
		per[i].name = name;
		per[i].age = age;
		per[i].wor = wor;
	}
        sort(per, per + n, cmp); //sort不要写在内部 , 写在外部 
	for(int i = 1; i <= k; i++){
		scanf("%d%d%d", &sum, &down, &up);
                //sort(per, per + n, cmp); //sort不要写在内部 , 写在外部 
		printf("Case #%d:\n", i);
		int cnt = 0;
		for(int j = 0; j < n; j++){
			if(per[j].age >= down && per[j].age <= up){
				printf("%s %d %d\n", per[j].name.c_str(), per[j].age, per[j].wor);
				cnt++;
			}
			if(cnt == sum)
				break;
		}
		if(cnt == 0)
			printf("None");
	}
	
	return 0;
}

优化代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int maxsize = 1e6 + 5;
struct Node{
	string name;
	int age, wor;
}per[maxsize], valid[10005];
int n, k, ages[201];
bool cmp(Node a, Node b){
	if(a.wor != b.wor)
		return a.wor > b.wor;
	else if(a.age != b.age)
		return a.age < b.age;
	else if(a.name != b.name)
		return a.name < b.name;
}
int main(){
	string name;
	int age, wor, sum, down, up , validnum = 0;
	scanf("%d%d", &n, &k);
	for(int i = 0; i < n; i++){
		cin >> name;
		scanf("%d%d", &age, &wor);
		per[i].name = name;
		per[i].age = age;
		per[i].wor = wor;
	}
	sort(per, per + n, cmp);
	for(int i = 0; i < n; i++){
		if(ages[per[i].age] < 100){
			valid[validnum++] = per[i]; 
			ages[per[i].age]++;
		}
	}
	for(int i = 1; i <= k; i++){
		scanf("%d%d%d", &sum, &down, &up);
		printf("Case #%d:\n", i);
		int cnt = 0;
		for(int j = 0; j < n; j++){
			if(valid[j].age >= down && valid[j].age <= up && j < validnum){
				printf("%s %d %d\n", valid[j].name.c_str(), valid[j].age, valid[j].wor);
				cnt++;
			}
			if(cnt == sum)
				break;
		}
		if(cnt == 0)
			printf("None");
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值