「1055」The World's Richest

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers:  - the total number of people, and  - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in ), and the net worth (integer in ) of a person. Finally there are K lines of queries, each contains three positive integers:  - the maximum number of outputs, and [AminAmax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [AminAmax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

Ω

又是一道名单罗列题,给出福布斯排行榜上所有用户的姓名、年龄和身价,需要你输出给定年龄段之间身价最高的前M位用户信息,若身价一致则按年龄降序排列,若年龄也一致则按姓名降序排列。不存在输出None。

没想到C++里有tuple这种神奇的数据结构,本质上是泛化的pair容器,是一个可以包含不同类型数据的结构体类型,那么用户信息就无需建class了。

由于最终需要输出指定年龄段之间身价最高的人,因此不能简单地通过几次sort就直接输出。但思想也很简单,按照【身价>年龄>姓名】的优先级对所有用户进行排序,然后从高身价开始遍历,同时计数符合给定年龄段的用户个数,一旦达到M便退出循环。

一开始懒得写compare函数,直接就sort了3次:

// sort name
sort(info.begin(),info.end(),[](tsii &a,tsii &b){return get<0>(a)< get<0>(b);});
// sort age 
sort(info.begin(),info.end(),[](tsii &a,tsii &b){return get<1>(a)< get<1>(b);});
// sort net worths
sort(info.begin(),info.end(),[](tsii &a,tsii &b){return get<2>(a)> get<2>(b);});

提交后发现有两个数据量较大的测试点挂了,可以说明一点:sort函数在处理大量数据时采用的不是稳定排序算法,即在cmp函数中满足 (注意cmp函数必须严格弱序)的两个对象 在排序后次序会和原先不同(P.s. 事实上稳定排序可以用stable_sort函数)。所以只能自己写个cmp函数了:

bool cmp(tsii &a, tsii &b)
{
    if (get<2>(a) != get<2>(b))
        return get<2>(a) > get<2>(b);
    else if(get<1>(a) != get<1>(b))
        return get<1>(a) < get<1>(b);
    else
        return get<0>(a) < get<0>(b);
}

🐎

#include <iostream>
#include <vector>
#include <tuple>
#include <algorithm>

using namespace std;
typedef tuple<string, int, int> tsii;

inline bool cmp(tsii &a, tsii &b)
{
    if (get<2>(a) != get<2>(b))
        return get<2>(a) > get<2>(b);
    else if (get<1>(a) != get<1>(b))
        return get<1>(a) < get<1>(b);
    else
        return get<0>(a) < get<0>(b);
}

int main()
{
    vector<tsii> info;
    int n, k, age, net;
    string name;
    cin >> n >> k;
    for (int i = 0; i < n; ++i)
    {
        cin >> name >> age >> net;
        info.emplace_back(name, age, net);
    }
    sort(info.begin(), info.end(), &cmp);
    int m, amin, amax, cnt;
    for (int i = 0; i < k; ++i)
    {
        cnt = 0;
        cin >> m >> amin >> amax;
        printf("Case #%d:\n", i + 1);
        for (auto &t: info)
            if (get<1>(t) >= amin && get<1>(t) <= amax)
            {
                printf("%s %d %d\n", get<0>(t).c_str(), get<1>(t), get<2>(t));
                if (++cnt == m)
                    break;
            }
        if (cnt == 0)
            printf("None\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值