1145 Hashing - Average Search Time (hash平方探测法)

1145 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

 /**
本题题意
     使用hash表, 顶一个,(平方探测法解决冲突)
     本题给定hash表的最大尺寸,输入n个数进入hash表中
     (如果hash表不能存放 n个数,就输出不能插入hash表的数字)
     然后给定m个数, 需要出这m个数是否出现在hash表中,并记录它们
     的出现次数,并输出(记录次数需要注意的是,
     1.hash表中,记录次数使用的 平方探测法
     的范围是从 0 - tsize (并不是到tsize - 1))  
     2.当探测到 hashTable[pos] == 0时 说明这个元素肯定不存在, 就不需要继续探测了
**/

 

#include<iostream>
#include<vector> 
#include<cmath>
using namespace std;
const int maxsize = 1e5 + 5;
int n, m, tsize, hashTable[maxsize];
bool isexist;
bool isprime(int tsize){
	for(int i = 2; i <= (int)sqrt(tsize); i++){
		if(tsize % i == 0)
			return false;
	}
	return true;
}
int main(){
	scanf("%d%d%d", &tsize, &n, &m);
	int num;
	double sum = 0.0;
	while(!isprime(tsize)) tsize++;
	for(int i = 0; i < n; i++){
		scanf("%d", &num);
		for(int j = 0; j <= tsize; j++){
			int pos = (num + j * j) % tsize;
			if(hashTable[pos] == 0){
				isexist = true;
				hashTable[pos] = num;
				break;
			}
		}
		if(isexist){
			isexist = false;
		}else{
			printf("%d cannot be inserted.\n",  num);
		}
	}
	for(int i = 0; i < m; i++){
		scanf("%d", &num);
		for(int j = 0; j <= tsize; j++){
			int pos = (num + j * j) % tsize;
			if(hashTable[pos] == 0){
				sum++;
				break;
			} 
			if(hashTable[pos] == num){
				sum++;
				break;
			}
			sum++;
		}
	}
	printf("%.1f\n", sum / m); 
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值