【蓝桥杯】算法提高 十进制数转八进制数

编写函数,其功能为把一个十进制数转换为其对应的八进制数。程序读入一个十进制数,调用该函数实现数制转换后,输出对应的八进制数。

 样例输入
 9274
 样例输出
 22072
样例输入
 18
 样例输出
 22
#include <iostream>
#include <cstdio>
#include <math.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <stack>
using namespace std;

typedef long long ll;

void reverse(ll n){
	stack<int> s;
	while(n){
		int temp = n % 8;
		s.push(temp);
		n /= 8;
	}
	
	while(!s.empty()){
		cout<<s.top();
		s.pop();
	}
	cout<<endl;
}

int main(){
	
	ll n;
	cin>>n;
	
	reverse(n);
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值