UVA 10815 - Andy's First Dictionary

题目链接:

          Andy's First Dictionary

题目:

Andy, 8, has a dream - he wants to produce hisvery own dictionary. This is not an easy task forhim, as the number of words that he knows is,well, not quite enough. Instead of thinking up allthe words himself, he has a briliant idea. Fromhis bookshelf he would pick one of his favouritestory books, from which he would copy out allthe distinct words. By arranging the words inalphabetical order, he is done! Of course, it isa really time-consuming job, and this is where acomputer program is helpful.You are asked to write a program that listsall the different words in the input text. In thisproblem, a word is defined as a consecutive sequenceof alphabets, in upper and/or lower case.Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE.For example, words like “Apple”, “apple” or “APPLE” must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Inputis terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. Thewords should all be in lower case, sorted in alphabetical order. You can be sure that he number ofdistinct words in the text does not exceed 5000.

Sample Input   

Adventures in DisneylandTwo blondes were going to Disneyland when they came to a fork in theroad. The sign read: "Disneyland Left."So they went home.

Sample Output

a

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when


简单题

这题还可以用 stringstream  (头文件:#include <sstream>)

我也是第一次用,看博客了解了一下。不了解的可以看看下面这个博客

   string和stringstream用法总结  


AC代码:

#include <set>
#include <cstdio>
#include <string>
#include <sstream>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
set < string > sss;
int main()
{
    string s,c;
    while(cin >> s)
    {
        for (int i=0; i<s.length(); i++)
        {
            if (isalpha(s[i]))        //检查字符是否为字母
                s[i]=tolower(s[i]);   //转化为小写
            else
                s[i]=' ';
        }
        stringstream ss(s);
        while(ss>>c)
            sss.insert(c);
    }
    for (set<string>::iterator it = sss.begin(); it!=sss.end(); it++)
        cout << *it << endl;
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值