二分搜索 AOJ ALDS1_4_B:Binary Search

题目网址链接:

http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=ALDS1_4_B

Search - Binary Search

Time Limit : 1 sec, Memory Limit : 131072 KB 

 

Search II

You are given a sequence of n integers S and a sequence of different q integers T. Write a program which outputs C, the number of integers in T which are also in the set S.

Input

In the first line n is given. In the second line, n integers are given. In the third line q is given. Then, in the fourth line, q integers are given.

Output

Print C in a line.

Constraints

  • Elements in S is sorted in ascending order
  • n ≤ 100000
  • q ≤ 50000
  • 0 ≤ an element in S ≤ 109
  • 0 ≤ an element in T ≤ 109

Sample Input 1

5
1 2 3 4 5
3
3 4 1

Sample Output 1

3

Sample Input 2

3
1 2 3
1
5

Sample Output 2

0

Sample Input 3

5
1 1 2 2 3
2
1 2

Sample Output 3

2

 

题意:

请编写一个程序,输入包含n个整数的数列S以及包含q个不重复整数的数列T,输出既包含于T也包含于S的整数的个数C

 

题目分析:

二分查找。

方法一:

利用C++ STL 中自带的二分查找函数(需要借助容器vector)

binary_search(v.begin(), v.end(), number_to_find);

 

C++代码实现如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <iterator>
using namespace std;

int main()
{
    int n, q, x;
    int ans = 0;
    vector<int> a, b;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> x;
        a.push_back(x);
    }
    cin >> q;
    for (int j = 0; j < q; j++)
    {
        cin >> x;
        b.push_back(x);
    }
    sort(a.begin(), a.end());
    for (vector<int>::iterator it = b.begin(); it != b.end(); it++)
    {
        if (binary_search(a.begin(), a.end(), *it))
            ans++;
    }
    cout << ans << endl;
    return 0;
}


 

方法二:

利用C++ STL函数lower_bound()

 

lower_bound()的前两个参数是指针类型,用来指定作为对象的数组或容器的范围。

比如int A[14]; lower_bound(A, A + 14, 3).它指定了数组A 的头指针以及距离头指针14的位置,即数组的末尾的后一位。如果A是vector,则可使用A.begin(), A.end()来指定范围。lower_bound()的第3个参数用于指定value。

lower_bound(A, A + 14, 3)函数最终返回一个vecotr中的不小于3的最小值的地址。

即:

*lower_bound(v.begin(), v.end(), value) = {k| k is in the vector subject to k is the minimum number which is not less than value};

 

C++代码实现如下:

#include <iostream>
#include <vector>
#include <algorithm>
#include <iterator>
using namespace std;

int main()
{
    int n, q, x;
    int ans = 0;
    vector<int> a, b;
    cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> x;
        a.push_back(x);
    }
    cin >> q;
    for (int j = 0; j < q; j++)
    {
        cin >> x;
        b.push_back(x);
    }
    sort(a.begin(), a.end());
    for (vector<int>::iterator it = b.begin(); it != b.end(); it++)
    {
        if (*lower_bound(a.begin(), a.end(), *it) == *it)
            ans++;
    }
    cout << ans << endl;
    return 0;
}


 

 

方法三:

自编二分查找函数

遍历数列T的每个元素,对于每个元素,利用find二分查找这个元素是否在数列S中。

如果在,则计数器ans++

 

对于二分查找函数

bool find(int *a, int n, int m, int left, int right, int sum) ,

说明如下:

a代表数组,n是元素个数,m是要查询的数,left是二分最左端,right是二分最右端,sum记录递归的次数

 

C++代码实现如下:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;

int a[100001];
int b[50001];

bool find(int *a, int n, int m, int left, int right, int sum) // a代表数组,n是元素个数,m是要查询的数,left是二分最左端,right是二分最右端,sum记录递归的次数
{
	if (pow(2, sum)  > n + 10) // 如果递归次数超过二分正常的次数log2(n)
		return false;
	if (a[left] == m)
		return true;
	if (a[right] == m)
		return true;
	int mid = (left + right) / 2;
	if (m == a[mid])
		return true;
	else if (m < a[mid])
	{
		right = mid;
		find(a, n, m, left, right, sum + 1); // 递归
	}
	else
	{
		left = mid;
		find(a, n, m, left, right, sum + 1); // 递归
	}
}

int main()
{
	int n, q;
	int sum = 0;
	int ans = 0;
	scanf ("%d", &n);
	for (int i = 0; i < n; i++)
		scanf ("%d", &a[i]);
	scanf ("%d", &q);
	for (int i = 0; i < q; i++)
		scanf ("%d", &b[i]);
	sort(a, a + n);
	for (int i = 0; i < q; i++)
		if (find(a, n, b[i], 0, n - 1, sum)) // 二分查找
			ans++;
	cout << ans << endl;
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值