51Nod 2178 ProjectEuler 10 c/c++题解

题目描述

所有小于10的质数的和是2 + 3 + 5 + 7 = 17。
输入n,求所有小于等于n的质数之和。
输入
输入第一行组数T,
接下来T行,每行一个整数n。
(1 <= T <= 10)
(1 <= N <= 2000000)
输出
对于每组数据,输出一个数,表示所有小于等于n的质数之和。
输入样例
3
5
10
2000000
输出样例
10
17
142913828922

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <deque>
#include <list>
#include <utility>
#include <set>
#include <map>
#include <stack>
#include <queue>
#include <bitset>
#include <iterator>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const ll  INF = 0x3f3f3f3f3f3f3f3f;
const double PI = acos(-1.0);
const double E = exp(1.0);
const int MOD = 1e9+7;
const int MAX = 1e7+5;
int t,n;
set <int> prime;
int check[MAX];
void get_prime()//埃筛素数
{
	memset(check,0,sizeof(check));
	//int tot = 0;
	for(int i = 2; i <= MAX; i++)
	{
		if(!check[i])
		{
			//prime[tot++] = i;
			prime.insert(i);
			for(int j = 2*i; j <= MAX; j += i)
			{
				check[j] = 1;
			}
		}
	}
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);

    get_prime();

    cin >> t;
    while(t--)
    {
        cin >> n;
        set <int>:: iterator pos;
        pos = prime.lower_bound(n);
        if(*pos == n)
            pos++;
        ll sum = 0;
        for(auto it = prime.begin(); it != pos; it++)
        {
            sum += *it;
        }
        cout << sum << endl;
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值