Sum 【HDU - 4704】【欧拉降幂】

Input

2

Output

2

        
 

Hint

1. For N = 2, S(1) = S(2) = 1. 2. The input file consists of multiple test cases.

Sample Input

2

Sample Output

2

        
  

Hint

1.  For N = 2, S(1) = S(2) = 1.

2.  The input file consists of multiple test cases. 

        
 

 题意

  题目让我们求的是2的N次幂,但由于N过大,所以需要用到欧拉降幂公式。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <limits>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#define lowbit(x) ( x&(-x) )
using namespace std;
typedef long long ll;
const ll mod=1e9+7;
const ll phi=1e9+6;
ll ans=0;
char s[100005];
ll mi(ll x, ll y)
{
    ll res=1;
    while(y)
    {
        if(y&1)
        {
            res=res*x%mod;
        }
        x=x*x%mod;
        y>>=1;
    }
    return res;
}
int main()
{
    while(scanf("%s",s)!=EOF)
    {
        ans=0;
        int len=(int)strlen(s);
        for(int i=0; i<len; i++)
        {
            ans=(ans*10+s[i]-'0')%phi;
        }
        printf("%lld\n",mi(2, (ans+phi-1)%phi));
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Wuliwuliii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值