One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).
Then L slices are given. Each slice is represented by an M×N matrix of 0’s and 1’s, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1’s to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.
figstroke.jpg
Figure 1
Output Specification:
For each case, output in a line the total volume of the stroke core.
Sample Input:
3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0
Sample Output:
26
思路:每次遇到为访问的点,并且点的值是1,bfs访问,并且把所有访问过的vis设为true。
测试点4和5错误原因,三维数组大小是否正确。
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
int brain[70][1330][130], m, n, l, num, least, res = 0;
bool vis[70][1330][130] = { false };
int x[] = { 0,0,1,-1,0,0 };
int y[] = { 0,0,0,0,1,-1 };
int z[] = { 1,-1,0,0,0,0 };
struct ss {
int x, y, z;
ss(int num1, int num2, int num3) {
x = num1; y = num2; z = num3;
}
};
bool judge(int x, int y, int z) {
if (x < 0 || x >= m || y < 0 || y >= n || z < 0 || z >= l || vis[z][x][y] == true||brain[z][x][y]==0)
return false;
return true;
}
int bfs(ss index) {
int sum = 0;
queue<ss > q;
vis[index.z][index.x][index.y] = true;
q.push(index);
while (!q.empty()) {
ss temp = q.front();
q.pop();
sum++;
for (int i = 0; i < 6; i++) {
int newx = temp.x + x[i], newy = temp.y + y[i], newz = temp.z + z[i];
if (judge(newx, newy, newz)) {
vis[newz][newx][newy] = true;
ss next(newx,newy,newz);
q.push(next);
}
}
}
return sum;
}
int main() {
cin >> m >> n >> l >> least;
for (int z = 0; z < l; z++) {
for (int x = 0; x < m; x++) {
for (int y = 0; y < n; y++) {
scanf("%d", &num);
brain[z][x][y] = num;
}
}
}
for (int z = 0; z < l; z++) {
for (int x = 0; x < m; x++) {
for (int y = 0; y < n; y++) {
if (vis[z][x][y] == false && brain[z][x][y] == 1) {
ss temp(x, y, z);
int ans=bfs(temp);
if (ans >= least)
res += ans;
}
}
}
}
cout << res << endl;
}