The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1≤NC,NP≤105, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
思路:贪心,两序列每次取最大正数相乘,最小负数相乘求和。
#include <iostream>
#include <cstdio>
#include <map>
#include <vector>
#include <string>
#include <memory.h>
#include <set>
#include <stack>
#include <queue>
#include <unordered_map>
#include <iomanip>
#include <algorithm>
#include <cmath>
using namespace std;
bool cmp(int a, int b) {
return a > b;
}
int main() {
vector<int > v1z, v1f, v2z, v2f;
int n, num;
cin >> n;
for (int i = 0; i < n; i++) {
cin >> num;
if (num > 0)
v1z.push_back(num);
else
v1f.push_back(num);
}
cin >> n;
for (int i = 0; i < n; i++) {
cin >> num;
if (num > 0)
v2z.push_back(num);
else
v2f.push_back(num);
}
sort(v1z.begin(), v1z.end(),cmp);
sort(v2z.begin(), v2z.end(),cmp);
sort(v1f.begin(), v1f.end());
sort(v2f.begin(), v2f.end());
int sum = 0;
for (int i = 0; i < v1f.size() && i < v2f.size(); i++) {
sum += v1f[i] * v2f[i];
}
for (int i = 0; i < v1z.size() && i < v2z.size(); i++) {
sum += v1z[i] * v2z[i];
}
cout << sum << endl;
}