poj 1015 Jury Compromise(一道很老很经典的二维dp)

目录

 

题目:

题目大意:

思路:

状态转移方程:

AC代码:


题目:

poj 1015 题目链接

Jury Compromise

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31847 Accepted: 8592 Special Judge

Description

In Frobnia, a far-away country, the verdicts in court trials are determined by a jury consisting of members of the general public. Every time a trial is set to begin, a jury has to be selected, which is done as follows. First, several people are drawn randomly from the public. For each person in this pool, defence and prosecution assign a grade from 0 to 20 indicating their preference for this person. 0 means total dislike, 20 on the other hand means that this person is considered ideally suited for the jury. 
Based on the grades of the two parties, the judge selects the jury. In order to ensure a fair trial, the tendencies of the jury to favour either defence or prosecution should be as balanced as possible. The jury therefore has to be chosen in a way that is satisfactory to both parties. 
We will now make this more precise: given a pool of n potential jurors and two values di (the defence's value) and pi (the prosecution's value) for each potential juror i, you are to select a jury of m persons. If J is a subset of {1,..., n} with m elements, then D(J ) = sum(dk) k belong to J 
and P(J) = sum(pk) k belong to J are the total values of this jury for defence and prosecution. 
For an optimal jury J , the value |D(J) - P(J)| must be minimal. If there are several jurys with minimal |D(J) - P(J)|, one which maximizes D(J) + P(J) should be selected since the jury should be as ideal as possible for both parties. 
You are to write a program that implements this jury selection process and chooses an optimal jury given a set of candidates.

Input

The input file contains several jury selection rounds. Each round starts with a line containing two integers n and m. n is the number of candidates and m the number of jury members. 
These values will satisfy 1<=n<=200, 1<=m<=20 and of course m<=n. The following n lines contain the two integers pi and di for i = 1,...,n. A blank line separates each round from the next. 
The file ends with a round that has n = m = 0.

Output

For each round output a line containing the number of the jury selection round ('Jury #1', 'Jury #2', etc.). 
On the next line print the values D(J ) and P (J ) of your jury as shown below and on another line print the numbers of the m chosen candidates in ascending order. Output a blank before each individual candidate number. 
Output an empty line after each test case.

Sample Input

4 2 
1 2 
2 3 
4 1 
6 2 
0 0 

Sample Output

Jury #1 
Best jury has value 6 for prosecution and value 4 for defence: 
 2 3 

Hint

If your solution is based on an inefficient algorithm, it may not execute in the allotted time.

题目大意:

n个人中选出m个人,每个人有两种属性,要求选出来的m个人的属性差之和最小,如果有多解输出属性和最大的那一组。

思路:

这题可以采取0,1背包的思路,将选出人数看作背包容量,采取价值最小的解,同时规划价值最小的中价值最大的取法,由于需要输出路径,所以需要一个记录路径的数组,由于不知道第三维度大小采用vector数组。

状态转移方程:dp[i + 1][j + gap[k]]=dp[i][j]+sum[k]

dp数组的第一个维度是选出人数,即使用背包容量,第二维度为当前价值,规划当前最大的情况。gap数组记录的是属性差,sum数组记录的是属性和。

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<ctime>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
int dp[27][1007],sum[1007],gap[1007];
vector<int> path[207][1007];
int main()
{
    ios::sync_with_stdio(false);
    int n,m,o = 0;
    while(cin >> n >> m && n){
        memset(dp,-1,sizeof dp);
        int x,y,i;
        for(int i = 0;i < m;++i)
            for(int j = 0;j < 1007;++j)
                path[i][j].clear();
        for(int i = 0;i < n;++i){
            cin >> x >> y;
            sum[i] = x + y;
            gap[i] = x - y;
        }
        int max_s = 20 * m;
        dp[0][max_s] = 0;
        for(int i = 0;i < n;++i)
            for(int j = m - 1;j >= 0;--j)
                for(int k = 0;k < 2 * max_s;++k){
                    if(dp[j][k] >= 0 && dp[j + 1][k + gap[i]] <= dp[j][k] + sum[i]){
                        dp[j + 1][k + gap[i]] = dp[j][k] + sum[i];
                        path[j + 1][k + gap[i]] = path[j][k];
                        path[j + 1][k + gap[i]].push_back(i);
                    }
                }
        for(i = 0;dp[m][max_s + i] == -1 && dp[m][max_s - i] == -1;++i) ;
        int index = dp[m][max_s + i] > dp[m][max_s - i] ? i : -i;
        int maxn = (dp[m][max_s + index] + index) / 2,minn = (dp[m][max_s + index] - index) / 2;
        cout << "Jury #" << ++o << endl;
        cout << "Best jury has value " << maxn << " for prosecution and value " << minn << " for defence:" << endl;
        for(int i = 0;i < m;++i) cout << " " << path[m][max_s + index][i] + 1;
        cout << endl;
        cout << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值