PAT A1002 A+B for Polynomials (25 分)(C语言实现&C++语言实现)

PAT A1002 A+B for Polynomials (25 分)(C语言实现&C++语言实现)

问题描述

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2 

思路

  1. 题目的意思是,给出两行多项式,每一行第一个是指多项式个数,后面均为幂次 项数,将两个和到一起进行输出;
  2. 就直接定义一个数组输出就好了,有想过使用类或者结构体,这样的代码复杂度增加,而且,在每一次输入的时候都要多一次循环?!反正就是比直接用数组慢;
  3. 最后计算个数的循环我真的无能,还是老老实实的用普普通通的循环,在想要不要建立一个数组储存幂,后面想一想,其实相差不大。

代码

//C语言和C++语言都可以,我就没有单独去思考C++的了,主要是没想到啥比较间接的。
#include<stdio.h>
int main()
{
    double y[1010]={0};
    double x;
    int k,mi;
    scanf("%d",&k);
    while(k)
    {
        scanf("%d %lf",&mi,&x);
        y[mi]+=x;
        k--;
    }
    scanf("%d",&k);
    while(k)
    {
        scanf("%d %lf",&mi,&x);
        y[mi]+=x;
        k--;
    }
    k=0;
    for(int i=1009;i>=0;i--) if(y[i]!=0) k++;
    printf("%d",k);
    for(int i=1009;i>=0;i--)
    {
        if(y[i]!=0)printf(" %d %.1lf",i,y[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值