Least Common Multiple

Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.



 


Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


 


Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


 


Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


 


Sample Output

105
10296
#include<stdio.h>
long long LCM(long long temp1,long long temp2)
{
	long long temp;
	long long a;
	if(temp1<temp2){
		temp=temp1;
		temp1=temp2;
		temp2=temp;
	}
	long long b=temp1*temp2;
	while(temp2!=0)
	{
		a=temp2;
		temp2=temp1%temp2;
		temp1=a;
	}
	return b/temp1;
}
int main()
{
	int N;
	scanf("%d",&N);
	while(N--)
	{
		int M,i;
		long long temp1=1,temp2;
		scanf("%d",&M);
		for(i=1;i<=M;i++)
		{
			scanf("%lld",&temp2);
			temp1=LCM(temp1,temp2);
		}
		printf("%lld\n",temp1);
	}
	return 0;
}

其实这道题对于初学者来说有一定的难度,但仔细想想,还是能出来的。

思路:每两个数进行一次最小公倍数的计算,一直遍历到最后一个数。

但你编出来之后却发现WP,也许是你的定义的值太小啦,把数定义为long long型,再试一次,就ac啦。


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值