P1879 [USACO06NOV]玉米田Corn Fields (状压DP)

P1879 [USACO06NOV]玉米田Corn Fields

题目描述

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can’t be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

农场主John新买了一块长方形的新牧场,这块牧场被划分成M行N列(1 ≤ M ≤ 12; 1 ≤ N ≤ 12),每一格都是一块正方形的土地。John打算在牧场上的某几格里种上美味的草,供他的奶牛们享用。

遗憾的是,有些土地相当贫瘠,不能用来种草。并且,奶牛们喜欢独占一块草地的感觉,于是John不会选择两块相邻的土地,也就是说,没有哪两块草地有公共边。

John想知道,如果不考虑草地的总块数,那么,一共有多少种种植方案可供他选择?(当然,把新牧场完全荒废也是一种方案)

输入输出格式

输入格式:

第一行:两个整数M和N,用空格隔开。

第2到第M+1行:每行包含N个用空格隔开的整数,描述了每块土地的状态。第i+1行描述了第i行的土地,所有整数均为0或1,是1的话,表示这块土地足够肥沃,0则表示这块土地不适合种草。

输出格式:

一个整数,即牧场分配总方案数除以100,000,000的余数。

输入输出样例

输入样例#1

2 3
1 1 1
0 1 0

输出样例#1:

9

这道题因为所给的数据之含0和1,可以想到二进制,并且每个格子有选与不选两种,数据量也不大,所以可以用状压来做。
1来表示选,0来表示不选。
首先来确定一行的状态,然后递推剩下行的状态。遍历所有状态找出可行的状态。
判断一行内可行的方法是:vis[i]&&((i&ma[j])==j)
判断上下两行可行的方法是:k&j==0,如果k&j==0,说明dp[i-1][k]对dp[i][j]无影响

#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;
const int mod = 100000000;
const int MAXN = 4000 + 10;
int mp[20][20], ma[20], dp[20][MAXN]; //mp草地,dp表示第i行状态为j的方案总数
bool vis[MAXN] = {false};             //记录可行状态
int n, m;                             //n行m列
int main()
{
    // freopen("test.txt", "r", stdin);
    cin >> n >> m;
    for (int i = 0; i < n; i++)
    {
        for (int j = 0; j < m; j++)
        {
            cin >> mp[i][j];
            ma[i] = (ma[i] << 1) + mp[i][j]; //把每一行转为二进制
        }
    }
    int mx = (1 << m);           //一行一共mx种状态
    for (int i = 0; i < mx; i++) //枚举每种状态
    {
        if ((((i << 1) & i) == 0)) //如果是1表示有1相邻,不可行
        {
            vis[i] = true;
        }
    }
    for (int i = 0; i < mx; i++) //第一行枚举所有状态,并判断可行的状态
    {
        if ((vis[i]) && ((i & ma[0]) == i)) //可行的种植与题目所给的种植是否匹配
        {
            dp[0][i] = 1; //第一行i种种植状态方案数为1
        }
    }
    for (int i = 1; i < n; i++) //枚举剩下n-1行
    {
        for (int j = 0; j < mx; j++) //每一行都有mx种状态
        {
            if ((vis[j]) && ((j & ma[i]) == j))
            {
                for (int k = 0; k < mx; k++)
                {
                    if ((k & j) == 0) //两行之间各自合法
                    {
                        dp[i][j] = (dp[i][j] + dp[i - 1][k]) % mod;
                    }
                }
            }
        }
    }
    ll ans = 0;
    for (int i = 0; i < mx; i++)
    {
        ans = (ans + dp[n - 1][i]) % mod;
    }
    cout << ans << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值