算法竞赛进阶指南 POJ-1734.Sightseeing trip(Floyd算法)

1734.Sightseeing trip

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route.

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, …, y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,…,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+…+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string ‘No solution.’ in case there isn’t any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

题意

给定一个无向图,求图中一个至少包含3个点的环,环上的结点不重复,并且环上的边的长度之和最小。该问题称为无向图的最小环问题。在本题中,你需要输出最小环的方案,若最小环不唯一,输出任意一个均可。若无解,输出“No solution.”。图的结点数不超过100.

思路

考虑Floyd算法的过程。当外层循环k刚开始时,d[i,j]保存着“经过编号不超过k-1的结点”从i到J的最短路长度。
于是,min{d[i,j] + a[j,k] + a[k,i]}(1<=i<j<k),满足以下两个条件的最小环长度:

  1. 由编号不超过k的结点构成
  2. 经过结点k
  3. d[i,j]保存的最短路径还没有经过结点k。(可能经过k后,i,j之间的路径会变短,但此时还没有经过k)

上式中的i,j相当于枚举了环上与k相邻的两个点。所以以上结论显然成立。
对任意的k,1<=k<=n,取最小值,即可得到整张图的最小环。

因为环是至少由3个点组成的,所以所有枚举相邻的两条边,求第三条边的最短路

#include <iostream>
#include <algorithm>
#include <vector>
#include <cstdio>
#include <cstring>
using namespace std;

const int INF = 0x3f;
int a[310][310]; // 邻接表
int dist[310][310]; // 保存任意两点之间最短路径
int pos[310][310]; // 保存作为桥梁的那个点
int n,m;
int ans = 0x3f3f3f3f;
vector<int> path;
void get_path(int x,int y){
    if(pos[x][y] == 0) return;
    get_path(x,pos[x][y]);
    path.push_back(pos[x][y]);
    get_path(pos[x][y],y);
}
int main(){
    cin >> n >> m;
    memset(a,INF,sizeof(a));
    for(int i = 0;i <= n;i++){
        a[i][i] = 0;
    }
    for(int i = 0;i < m;i++){
        int u, v, w;
        cin >> u >> v >> w;
        a[u][v] = a[v][u] = min(a[u][v],w);
    }
    memcpy(dist,a,sizeof(a));
    for(int k = 1;k <= n;k++){
        for(int i = 1;i < k;i++){ // 先判断是否可以形成环
            for(int j = i + 1;j < k;j++){
                if((long long)dist[i][j] + a[j][k] + a[k][i] < ans){
                    ans = dist[i][j] + a[j][k] + a[k][i];
                    path.clear();
                    path.push_back(i);
                    get_path(i,j);
                    path.push_back(j);
                    path.push_back(k);
                }
            }
        }
        for(int i = 1;i <= n;i++){ // 求经过K的最短路径
            for(int j = 1;j <= n;j++){
                if(dist[i][j] > dist[i][k] + dist[k][j]){
                    dist[i][j] = dist[i][k] + dist[k][j];
                    pos[i][j] = k;
                }
            }
        }
    }
    if(ans == 0x3f3f3f3f){
        cout << "No solution." << endl;
    }
    else{
        for(int i = 0;i < (int)path.size();i++){
            cout << path[i] << " ";
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值