POJ 1734 Sightseeing trip Floyd求最小环

Sightseeing trip
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4394 Accepted: 1698 Special Judge

Description

There is a travel agency in Adelton town on Zanzibar island. It has decided to offer its clients, besides many other attractions, sightseeing the town. To earn as much as possible from this attraction, the agency has accepted a shrewd decision: it is necessary to find the shortest route which begins and ends at the same place. Your task is to write a program which finds such a route. 

In the town there are N crossing points numbered from 1 to N and M two-way roads numbered from 1 to M. Two crossing points can be connected by multiple roads, but no road connects a crossing point with itself. Each sightseeing route is a sequence of road numbers y_1, ..., y_k, k>2. The road y_i (1<=i<=k-1) connects crossing points x_i and x_{i+1}, the road y_k connects crossing points x_k and x_1. All the numbers x_1,...,x_k should be different.The length of the sightseeing route is the sum of the lengths of all roads on the sightseeing route, i.e. L(y_1)+L(y_2)+...+L(y_k) where L(y_i) is the length of the road y_i (1<=i<=k). Your program has to find such a sightseeing route, the length of which is minimal, or to specify that it is not possible,because there is no sightseeing route in the town.

Input

The first line of input contains two positive integers: the number of crossing points N<=100 and the number of roads M<=10000. Each of the next M lines describes one road. It contains 3 positive integers: the number of its first crossing point, the number of the second one, and the length of the road (a positive integer less than 500).

Output

There is only one line in output. It contains either a string 'No solution.' in case there isn't any sightseeing route, or it contains the numbers of all crossing points on the shortest sightseeing route in the order how to pass them (i.e. the numbers x_1 to x_k from our definition of a sightseeing route), separated by single spaces. If there are multiple sightseeing routes of the minimal length, you can output any one of them.

Sample Input

5 7
1 4 1
1 3 300
3 1 10
1 2 16
2 3 100
2 5 15
5 3 20

Sample Output

1 3 5 2

Source



题意是说给你一个无向图,让你判断是否存在环,如果存在输出边权和最小的环上的顶点。
因为100个点,所以用Floyd就可以解决。

#include<stdio.h>
#include<string.h>

#define M 107
#define inf 0x3f3f3f
using namespace std;
int g[M][M],dis[M][M],path[M][M],pre[M];
int n,m,num,mincircle;

void init()
{
    for(int i=1; i<=n; i++)
    {
        for(int j=1; j<=n; j++)
        {
            g[i][j]=dis[i][j]=inf;
        }
        g[i][i]=dis[i][i]=0;

    }
}

void dfs(int i,int j)
{
    int k=path[i][j];
    if(k==0)
    {
        pre[num++]=j;
        return ;
    }
    dfs(i,k);
    dfs(k,j);
}

void Floyd()
{
    mincircle=inf;
    for(int k=1; k<=n; k++)
    {
        for(int i=1; i<k; i++)//求环
            for(int j=i+1; j<k; j++)
            {
                if(mincircle>dis[i][j]+g[i][k]+g[k][j])
                {
                    mincircle=dis[i][j]+g[i][k]+g[k][j];
                    num=0;
                    pre[num++]=i;
                    dfs(i,j);
                    pre[num++]=k;
                }

            }
        for(int i=1; i<=n; i++)//求最短路
            for(int j=1; j<=n; j++)
                if(dis[i][k]+dis[k][j]<dis[i][j])
                {
                    dis[i][j]=dis[i][k]+dis[k][j];
                    path[i][j]=k;
                }
    }

}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        int a,b,c;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(g[a][b]>c)
            {
                g[a][b]=g[b][a]=c;
                dis[a][b]=dis[b][a]=c;
            }
        }
        memset(path,0,sizeof(path));
        Floyd();
        if(mincircle==inf)
            printf("No solution.\n");
        else
        {
            printf("%d",pre[0]);
            for(int i=1; i<num; i++)
                printf(" %d",pre[i]);
            printf("\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值