斐波那契问题

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

n<1000,000是个非常大的数,若果先求F(n)最后结果会很大,long long int也装不下,因此可以把取余后的数字存入一个数组num[1000000],然后再找能被3整除的数。

代码:

#include <iostream>
#include <cstdio>
const int N=1000000+5;
using namespace std;
long long f[N];
int main()
{
    int n;
    f[0]=7%3;
    f[1]=11%3;
     for(int i=2;i<=1000000;i++)
            f[i]=(f[i-1]+f[i-2])%3;
    while(scanf("%d",&n)!=EOF)
    {
            if(f[n]==0)
                printf("yes\n");
            else
                printf("no\n");
    }
    return 0;
}

/************补充:*************/

int(基本整形): -2的15次方~2的15次方-1                                         1000,00*3

long(长整型): -2的31次方~2的31次方-1                                     1000,000,000,000,000*2

long long(双长型): -2的63次方~2的63次方-1                              100000,00000,00000,0000*9

unsigned int(无符号基本整形): 0~2的16次方-1                           1000,00*6

unsigned long(无符号长整型): 0~2的32次方-1                            1000,000,000,0*4

unsigned long long(无符号双长整形): 0~2的64次方-1                 100000,00000,00000,00000*1

 

 

 

 

 

 

 

 
  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值