B - Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 

Input

n (0 < n < 20). 

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int ans[30];
int vis[30];
int n;

int Is_prime(int a,int b)
{
    int sum = a+b;
    int c=sqrt(sum)+1;
    for ( int i = 2; i < c; i++ )
    {
        if(sum%i==0)
            return false;
    }
    return true;
}

void dfs( int x)
{
    if( x == n && Is_prime(ans[n-1],1))//在经历一次dfs,因此x+1
    {
        for( int i = 0; i < n; i++)
        {
            if( i<n-1)
            printf("%d ",ans[i]);
            else
                printf("%d\n",ans[n-1]);
        }
        return;
    }
    if( x == n ) return;//没有遍历到底的要返回
    for( int i = 1; i < n; i++)
    {
        if( vis[i] == 0 && Is_prime(i+1,ans[x-1]))    //i,ans【x-1】,x相互对应好,我没对应正确,找了好久,快哭了
        {
            ans[x]=i+1;
            vis[i]=1;//标记               /******************************************************递归*/
            dfs(x+1);//return到这里/******************************************************分割线*/
            vis[i]=0;                        /********************************************************回溯*/
        }
    }

}
int main()
{
    int kase = 1;
    while(~scanf("%d",&n))
    {
        printf("Case %d:\n",kase++);
        memset(vis,0,sizeof(vis));
        vis[0]=1;
        ans[0]=1;
        dfs(1);
        printf("\n");
    }
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值