【POJ 2386 --- Lake Counting】DFS

【POJ 2386 --- Lake Counting】DFS


Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

  • Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

解题思路

采用深度优先搜索,从任意的w开始,不断把邻接的部分用’.‘代替,1次DFS后与初始这个w连接的所有w就全都被替换成’.’,因此直到图中不再存在W为止,总共进行DFS的次数就是答案。

AC代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int MAXN = 105;
char str[MAXN][MAXN];
int n,m;
int dir[2][8]{ {-1,0,1,1,1,0,-1,-1},{1,1,1,0,-1,-1,-1,0} };

void dfs(int x,int y)
{
    str[x][y]='.';
    for(int i=0;i<8;i++)
    {
        int dx=x+dir[0][i];
        int dy=y+dir[1][i];
        if(dx>=0 && dy>=0 && dx<n && dy<m && str[dx][dy]=='W')
            dfs(dx,dy);
    }
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)
        scanf("%s",str[i]);
    int ans=0;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            if(str[i][j]=='W')
                dfs(i,j),ans++;
    cout << ans << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值