【CodeForces 510B --- Fox And Two Dots】DFS水题

【CodeForces 510B --- Fox And Two Dots】DFS水题


Description

Fox Ciel is playing a mobile puzzle game called “Two Dots”. The basic levels are played on a board of size n × m cells, like this:

Each cell contains a dot that has some color. We will use different uppercase Latin characters to express different colors.

The key of this game is to find a cycle that contain dots of same color. Consider 4 blue dots on the picture forming a circle as an example. Formally, we call a sequence of dots d1, d2, …, dk a cycle if and only if it meets the following condition:

These k dots are different: if i ≠ j then di is different from dj.
k is at least 4.
All dots belong to the same color.
For all 1 ≤ i ≤ k - 1: di and di + 1 are adjacent. Also, dk and d1 should also be adjacent. Cells x and y are called adjacent if they share an edge.
Determine if there exists a cycle on the field.

Input

The first line contains two integers n and m (2 ≤ n, m ≤ 50): the number of rows and columns of the board.

Then n lines follow, each line contains a string consisting of m characters, expressing colors of dots in each line. Each character is an uppercase Latin letter.

Output

Output “Yes” if there exists a cycle, and “No” otherwise.

Sample Input

3 4
AAAA
ABCA
AAAA

Sample Output

Yes

解题思路

通过dfs搜索一波就行。

AC代码:

#include <iostream>
using namespace std;
int n,m;
const int MAXN = 55;
char str[MAXN][MAXN];
bool vis[MAXN][MAXN],flag=false;
int dir[4][2]={0,1,0,-1,-1,0,1,0};

void dfs(int x,int y,int xx,int yy)
{
    if(vis[x][y])
    {
        flag=true;
        return;
    }
    vis[x][y]=true;
    for(int i=0;i<4;i++)
    {
        int dx=x+dir[i][0];
        int dy=y+dir[i][1];
        if(dx==xx&&dy==yy) continue;
        if(dx>=0&&dy>=0&&dx<n&&dy<m&&str[dx][dy]==str[x][y])
            dfs(dx,dy,x,y);
        if(flag) return;
    }
}

int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    cout.tie(0);
    cin >> n >> m;
    for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
            cin >> str[i][j];
    for(int i=0;i<n&&!flag;i++)
        for(int j=0;j<m&&!flag;j++)
            if(!vis[i][j])
            {
                dfs(i,j,i,j);
                if(flag) break;
            }
    if(flag)
        cout << "Yes" << endl;
    else
        cout << "No" << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值