【CodeForces 1249D2 --- Too Many Segments [hard version]】

【CodeForces 1249D2 --- Too Many Segments [hard version]】


Description

The only difference between easy and hard versions is constraints.

You are given n segments on the coordinate axis OX. Segments can intersect, lie inside each other and even coincide. The i-th segment is [li;ri] (li≤ri) and it covers all integer points j such that li≤j≤ri.

The integer point is called bad if it is covered by strictly more than k segments.

Your task is to remove the minimum number of segments so that there are no bad points at all.

Input

The first line of the input contains two integers n and k (1≤k≤n≤2⋅105) — the number of segments and the maximum number of segments by which each integer point can be covered.

The next n lines contain segments. The i-th line contains two integers li and ri (1≤li≤ri≤2⋅105) — the endpoints of the i-th segment.

Output

In the first line print one integer m (0≤m≤n) — the minimum number of segments you need to remove so that there are no bad points.

In the second line print m distinct integers p1,p2,…,pm (1≤pi≤n) — indices of segments you remove in any order. If there are multiple answers, you can print any of them.

Sample Input

7 2
11 11
9 11
7 8
8 9
7 8
9 11
7 9

Sample Output

3
4 6 7

解题思路

遍历整个线段,判断每个点上覆盖次数,大于k时删除最长的那个。
详情看代码

AC代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <set>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
const int MAXN=200002;

struct Node
{
    int y,index;
};

vector<Node> v[MAXN];
vector<int> ans;

bool operator<(Node a,Node b)
{
    if(a.y!=b.y) return a.y<b.y;
    else return a.index<b.index;
}

int main()
{
    SIS;
    int n,k,x,y;
    cin >> n >> k;
    Node nd;
    for(int i=1;i<=n;i++)
    {
        cin >> x >> y;
        nd.y=y;
        nd.index=i;
        v[x].push_back(nd);
    }
    set<Node> s;
    for(int i=1;i<=MAXN;i++)
    {
        while(s.size() && (*s.begin()).y<i) s.erase(s.begin());
        for(int j=0;j<v[i].size();j++) s.insert(v[i][j]);
        while(s.size()>k)
        {
            ans.push_back((*s.rbegin()).index);
            s.erase(*s.rbegin());
        }
    }
    int len=ans.size();
    cout << len << endl;
    for(int i=0;i<len;i++)
        cout << ans[i] << (i==len-1?'\n':' ');
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 6
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 6
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值