【CodeForces 1265B --- Beautiful Numbers】

【CodeForces 1265B --- Beautiful Numbers】

题目来源:点击进入【CodeForces 1265B — Beautiful Numbers】

Description

You are given a permutation p=[p1,p2,…,pn] of integers from 1 to n. Let’s call the number m (1≤m≤n) beautiful, if there exists two indices l,r (1≤l≤r≤n), such that the numbers [pl,pl+1,…,pr] is a permutation of numbers 1,2,…,m.

For example, let p=[4,5,1,3,2,6]. In this case, the numbers 1,3,5,6 are beautiful and 2,4 are not. It is because:

  • if l=3 and r=3 we will have a permutation [1] for m=1;
  • if l=3 and r=5 we will have a permutation [1,3,2] for m=3;
  • if l=1 and r=5 we will have a permutation [4,5,1,3,2] for m=5;
  • if l=1 and r=6 we will have a permutation [4,5,1,3,2,6] for m=6;

it is impossible to take some l and r, such that [pl,pl+1,…,pr] is a permutation of numbers 1,2,…,m for m=2 and for m=4.
You are given a permutation p=[p1,p2,…,pn]. For all m (1≤m≤n) determine if it is a beautiful number or not.

Input

The first line contains the only integer t (1≤t≤1000) — the number of test cases in the input. The next lines contain the description of test cases.

The first line of a test case contains a number n (1≤n≤2⋅105) — the length of the given permutation p. The next line contains n integers p1,p2,…,pn (1≤pi≤n, all pi are different) — the given permutation p.

It is guaranteed, that the sum of n from all test cases in the input doesn’t exceed 2⋅105.

Output

Print t lines — the answers to test cases in the order they are given in the input.

The answer to a test case is the string of length n, there the i-th character is equal to 1 if i is a beautiful number and is equal to 0 if i is not a beautiful number.

Sample Input

3
6
4 5 1 3 2 6
5
5 3 1 2 4
4
1 4 3 2

Sample Output

101011
11111
1001

Note

The first test case is described in the problem statement.

In the second test case all numbers from 1 to 5 are beautiful:

  • if l=3 and r=3 we will have a permutation [1] for m=1;
  • if l=3 and r=4 we will have a permutation [1,2] for m=2;
  • if l=2 and r=4 we will have a permutation [3,1,2] for m=3;
  • if l=2 and r=5 we will have a permutation [3,1,2,4] for m=4;
  • if l=1 and r=5 we will have a permutation [5,3,1,2,4] for m=5.

解题思路:

排序后维护最大值位置mx和最小值位置mi,i=0依次遍历,当mx-mi==i时代表成立,反之为0;
具体看代码。

AC代码1:

#include <bits/stdc++.h>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 2e5+5;
pair<int,int> arr[MAXN];
 
int main()
{
    SIS;
    int T,n,x;
    cin >> T;
    while(T--)
    {
        cin >> n;
        int mi=0x3f3f3f3f,mx=0;
        for(int i=0;i<n;i++)
        {
            cin >> arr[i].first;
            arr[i].second=i;
        }
        sort(arr,arr+n);
        vector<int> v(n);
        for(int i=0;i<n;i++)
        {
            mi=min(arr[i].second,mi);
            mx=max(arr[i].second,mx);
            if(mx-mi==i) v[i]=1;
            else v[i]=0;
        }
        for(auto x:v) cout << x;
        cout << endl;
    }
    return 0;
}

仔细一想本题输入的是1-n的n个不重复的数,所以根本不需要排序。

AC代码2:

#include <bits/stdc++.h>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 2e5+5;
int arr[MAXN];

int main()
{
    SIS;
    int T,n,x;
    cin >> T;
    while(T--)
    {
        cin >> n;
        int mi=0x3f3f3f3f,mx=0;
        for(int i=1;i<=n;i++)
        {
            cin >> x;
            arr[x]=i;
        }
        vector<int> v(n);
        for(int i=1;i<=n;i++)
        {
            mi=min(arr[i],mi);
            mx=max(arr[i],mx);
            if(mx-mi==i-1) v[i-1]=1;
            else v[i-1]=0;
        }
        for(auto x:v) cout << x;
        cout << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值