Digital Deletions(博弈)

Digital deletions is a two-player game. The rule of the game is as following. 

Begin by writing down a string of digits (numbers) that's as long or as short as you like. The digits can be 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 and appear in any combinations that you like. You don't have to use them all. Here is an example: 



On a turn a player may either: 
Change any one of the digits to a value less than the number that it is. (No negative numbers are allowed.) For example, you could change a 5 into a 4, 3, 2, 1, or 0. 
Erase a zero and all the digits to the right of it. 


The player who removes the last digit wins. 


The game that begins with the string of numbers above could proceed like this: 



Now, given a initial string, try to determine can the first player win if the two players play optimally both. 

Input

The input consists of several test cases. For each case, there is a string in one line. 

The length of string will be in the range of [1,6]. The string contains only digit characters. 

Proceed to the end of file. 

Output

Output Yes in a line if the first player can win the game, otherwise output No. 

Sample Input

0
00
1
20

Sample Output

Yes
Yes
No
No

题意:对于一个数,我们有两种操作:

           ①:改变它的任意一位,使改变后的数小于原数(eg:0,1,2,... ,x)

           ②:删取任意位置的零,以及它右边的所有数

问:两个人轮流玩,第一个人能不能把这个数删完?

思路:由于两个人每次都是最优的,且每个人都可以改变任意一个位置的数, 因此,必胜态和必败态是轮流的。因此我们可以枚举所有必败态,改变它 的某一位使之成为必胜态,这样的话我们就可以直接通过标记来获取结果了。

代码如下:

/*
    对于一个数,我们有两种操作:
       ①:改变它的任意一位,使改变后的数小于原数(eg:0,1,2,... ,x)
       ②:删取任意位置的零,以及它右边的所有数
    问:两个人轮流玩,第一个人能不能把这个数删完?

    思路:由于两个人每次都是最优的,且每个人都可以改变任意一个位置的数,
          因此,必胜态和必败态是轮流的。因此我们可以枚举所有必败态,改变它
          的某一位使之成为必胜态。
*/

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int book[1000010];
int len(int x)
{
    int ans=0;
    while(x)
    {
        ans++;
        x/=10;
    }
    return ans;
}
void work(int x)
{
    int l=len(x);//求这个数的长度
    for(int i=l; i>=1; i--)//改变每一位的数
    {
        int y=x;
        int pos=1;
        for(int j=1; j<i; j++)//改变第 i 位上的数,因此求pos,用于下面只改变这一位的数
            pos*=10;
        int tmp=(x%(pos*10))/pos;//取x的第 i 位上的数
        for(int j=tmp; j<9; j++)//这个[tmp,9]
        {
            y=y+pos;//只有一位改变
            book[y]=1;//标记必胜态
        }
    }
    if(l!=6)//长度不足6位  后面补零
    {
        int y=x;
        int pos=1;
        for(int i=l; i<6; i++)
        {
            y=y*10;
            for(int j=0; j<pos; j++)//枚举后面的每一个数
                book[y+j]=1;
            pos*=10;
        }
    }
}
int main()
{
    book[0]=1;//0为必胜态
    for(int i=1; i<1000000; i++)//枚举1百万之内的所有数
        if(!book[i])//必败态
            work(i);
    char str[10];
    while(~scanf("%s",str))
    {
        if(str[0]=='0')
            printf("Yes\n");
        else
        {
            int sum=0;
            int l=strlen(str);
            for(int i=0; i<l; i++)
                sum=sum*10+str[i]-'0';
            if(book[sum])
                printf("Yes\n");
            else
                printf("No\n");
        }
    }
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值