HDU1425 sort -排序练习

给你n个整数,请按从大到小的顺序输出其中前m大的数。
Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。
Output
对每组测试数据按从大到小的顺序输出前m大的数。
Sample Input
5 3
3 -35 92 213 -644
Sample Output
213 92 3

AC代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int a[1000010];
int main(){
    int n, m,t,cnum;
    while(~scanf("%d%d",&n,&m)){
        memset(a,0,sizeof(a));
        for(int i = 0; i < n; i++){
            scanf("%d", &t);
            a[500000 + t]++;
        }
        cnum = 0;
        for(int i = 1000000; i >= 0; i--){
            if(cnum == m) break;
            while(a[i]){
                cnum++;
                a[i]--;
                if(cnum != m) cout<<i-500000<<" ";
                else cout <<i-500000<<endl;
            }
        }
    }
    return 0;
}

这个题还有其他的做法,但提交代码后都超时了
超时的代码是这样的

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
 
int Num[1000010];
 
int cmp(int a,int b)
{
    return a > b;
}
 
int main()
{
    int N,M;
    while(~scanf("%d%d",&N,&M))
    {
        for(int i = 0; i < N; ++i)
            scanf("%d",&Num[i]);
        sort(Num,Num+N,cmp);
        for(int i = 0; i < M; ++i)
            if(i != M-1)
                printf("%d ",Num[i]);
            else
                printf("%d\n",Num[i]);
    }
 
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值