PAT甲级1041 Be Unique

题目
1041 Be Unique (20 分)
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10
​4
​​ ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10
​5
​​ ) and then followed by N bets. The numbers are separated by a space.

Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None

题目意思
给你一个数组,找出第一个没重复的数,输出,若没有,则输出None

思路
爆搜会有一组数据过不了,运行时间超限。直接用桶排记录有没有重复。然后遍历判断的时候,找到了就break,节省时间。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

int hx[100003],mz[10003];

int main()
{
    int n,yy=0,q=0;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
    {
        scanf("%d",&hx[i]);
        mz[hx[i]]++;
    }
    for(int i=0;i<n;i++)
    {
        if(mz[hx[i]]==1)
        {
            q=1;
            yy=hx[i];
            break;
        }
    }
    if(!q)
        printf("None\n");
    else
        printf("%d\n",yy);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值