1023 Have Fun with Numbers

题目
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes
2469135798

题目意思
给你一个数,然后这个数乘以2,如果每个数字出现的次数跟之前的一样,就输出yes,否则就输出no

思路
本人秉承着,能模拟就模拟的原则,当然是模拟啦

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>

using namespace std;

int main()
{
    int hx[23],xc[23],sum,j=0,flag=0,i;
    char mz[23];
    scanf("%s",mz);
    for(i=0;i<strlen(mz);i++)
    {
        hx[i]=mz[i]-'0';
    }
    int sum1=i;
    for(i=sum1-1;i>=0;i--)
    {
        sum=hx[i]+hx[i]+flag;
        if(sum>9&&i!=0)
        {
            flag=1;
            xc[j++]=sum%10;
        }
        else if(i==0 && sum>9)
        {
            xc[j++] = sum%10;
            xc[j++] = sum/10;
        }
        else
        {
            xc[j++]=sum;
            flag=0;
        }
    }
    int a[10]={0},b[10]={0};
    for(i=0;i<sum1;i++)
    {
        a[hx[i]]++;
    }
    for(i=0;i<j;i++)
    {
        b[xc[i]]++;
    }
    flag=0;
    for(i=0;i<10;i++)
    {
        if(a[i]!=b[i])
        {
            flag=1;
            break;
        }
    }
    if(flag)
        printf("No\n");
    else
        printf("Yes\n");

    for(i=j-1;i>=0;i--)
        printf("%d",xc[i]);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值