1122 Hamiltonian Cycle (25 分)

12 篇文章 0 订阅
5 篇文章 0 订阅

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
#include<set>
#include<map>
using namespace std;
int n, m, k;
int graph[210][210] = { 0 };
set<int> s;
int main() {
	cin >> n >> m;
	for (int i = 0; i < m; i++) {
		int t1, t2;
		scanf("%d%d", &t1, &t2);
		graph[t1][t2] = graph[t2][t1] = 1;
	}
	cin >> k;
	for (int i = 0; i < k; i++) {
		int tmp;
		scanf("%d", &tmp);
		bool flag = 0;
		int st;
		s.clear();
		for (int j = 0; j < tmp; j++) {
			int v[1010];
			int t3;
			scanf("%d", &t3);
			v[j] = t3;
			if (j == 0) st = t3;
			else {
				if (j != tmp - 1) {
					if (s.find(t3) != s.end() && flag == 0) {
						flag = 1;
						printf("NO\n");
					}
				}
				else {
					if (t3 != st && flag == 0) {
						flag = 1;
						printf("NO\n");
					}
				}
				if (graph[v[j - 1]][v[j]] == 0 && flag == 0) {
					flag = 1;
					printf("NO\n");
				}
			}
			s.insert(t3);
		}
		if (tmp != n + 1 && flag == 0) printf("NO\n");
		else if (flag == 0 && tmp == n + 1) printf("YES\n");
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值