1037 Magic Coupon (25 分)(段错误原因)

360 篇文章 3 订阅
91 篇文章 1 订阅

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

结尾无空行
Sample Output:

43

结尾无空行

段错误原因:int 型范围不够,题目中说
在这里插入图片描述
已经超过了 int 的范围,所以不能使用 int,改成 long long int 直接 AC。

#include<iostream>
#include<string>
#include<algorithm>
#include<bits/stdc++.h>
#include<stack>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<deque>
#include<cctype>
#include<unordered_set>
#include<unordered_map>
#include<fstream>
#include<cstring>
using namespace std;
bool cmp (int a,  int b) {
	return a > b;
}
int main() {
	int n, m;
	cin >> n;
	long long int a[n];
	for (int i = 0; i < n; i++) {
		cin >> a[i];
	} 
	cin >> m;
	long long int b[m];
	for (int i = 0; i < m; i++) {
		cin >> b[i];
	}
	int i = 0, j = 0;
	sort(a, a + n, cmp);
	sort(b, b + m, cmp);
	long long int sum = 0;
	while (i < n && j < m && a[i] >= 0 && b[j] >= 0) {
		sum += (a[i++] * b[j++]);
	}
	i = n - 1, j = m - 1;
	while (i >= 0 && j >= 0 && a[i] <= 0 && b[j] <= 0) {
		sum += (a[i--] * b[j--]);
	}
	cout << sum;
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_努力努力再努力_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值