PAT甲级A1127 ZigZagging on a Tree (30 分)

29 篇文章 0 订阅
22 篇文章 0 订阅

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

zigzag.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

题意:给出一颗二叉树的中序和后序序列,让你按照‘z’字形 输出其层序遍历序列。

思路:首先根据模板,通过中序和后序序列建立一棵二叉树,然后层序遍历并把结果按照层次,保存在二维的vector中,然后把这个vector中奇数层的数据正序访问输出,偶数层逆序访问输出,即可得到结果。

参考代码:

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
	int v;
	node* lchild;
	node* rchild;
	node(int a):v(a),lchild(NULL),rchild(NULL){}
};
int n,in[35],post[35];
node* Create(int inl,int inr,int postl,int postr){	//中序和后序序列建树
	if(postl>postr) return NULL;
	node* root=new node(post[postr]);
	int k=inl;
	while(k<=inr&&in[k]!=post[postr]) k++;
	int numL=k-inl;
	root->lchild=Create(inl,k-1,postl,postl+numL-1);
	root->rchild=Create(k+1,inr,postl+numL,postr-1);
	return root;
}
void BFS(node* root){
	if(root==NULL) return;
	node* q[35];
	vector<int> v[35];
	int front=-1,rear=-1,last=0,level=0;		//数组q模拟队列,last记录本层最后结点编号,level记录层次
	q[++rear]=root;
	while(front!=rear){
		node* p=q[++front];
		v[level].push_back(p->v);
		if(p->lchild!=NULL) q[++rear]=p->lchild;
		if(p->rchild!=NULL) q[++rear]=p->rchild;
		if(front==last){	//一旦本层访问完毕,更新last和level
			last=rear;
			level++;
		}
	}
	for(int i=0;i<level;i++){		
		if(i%2==0){							//偶数层逆序输出
			for(int j=v[i].size()-1;j>=0;j--){
				if(v[i][j]!=root->v) printf(" ");
				printf("%d",v[i][j]);
			}
		}else{								//奇数层正序输出
			for(int j=0;j<v[i].size();j++){
				if(v[i][j]!=root->v) printf(" ");
				printf("%d",v[i][j]);
			}
		}
	}
}
int main()
{
	scanf("%d",&n);
	for(int i=0;i<n;i++)
		scanf("%d",&in[i]);
	for(int i=0;i<n;i++)
		scanf("%d",&post[i]);
	node* root=NULL;
	root=Create(0,n-1,0,n-1);
	BFS(root);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值