1017 Queueing at Bank (25 分)

    Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​4​​) - the total number of customers, and K (≤100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:

7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10

Sample Output:

8.2

        有n个客户,k个窗口。已知每个客户的到达时间和需要的时长(先来的先服务),求平均时长。

分析:可以利用结构体存储客户到达的时间和需要的时长,按照先来先服务的原则自定义排序。排好序后用一个二重循环,第一层是顾客,第二层是窗口,对于还未被服务的顾客要找到最早可以结束当前工作的窗口。

这样,若是当前窗口结束的时间比顾客来的时间还早,那么顾客就不用等待了,直接可以被服务,此时更新当前窗口结束工作的时间(即=顾客到达时间+顾客需要时长)。若是当前窗口结束工作的时间比顾客到达的时间要晚,那么顾客就需要等待一定的时长,此时更新等待时长,更新当前窗口的结束工作时间。

二重循环后,每一个顾客都回找到一个窗口,等待时长也会计算出来。(看的柳神的)

柳神原文

code:

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
const int maxtime=17*3600;
struct node {
	int come;
	int process_time;
};
bool cmp(node a,node b) {
	if(a.come!=b.come) {
		return a.come<b.come;
	}
}
int main() {
	int n,k,h,m,s,t,ct;
	double wait=0.0;
	node a;
	scanf("%d %d",&n,&k);
	vector<node>custom;
	for(int i=1; i<=n; i++) {
		scanf("%d:%d:%d %d",&h,&m,&s,&t);
		ct=h*3600+m*60+s;
		if(ct>maxtime) continue;
		else {
			a.come=ct;
			a.process_time=t*60;
			custom.push_back(a);
		}
	}
	sort(custom.begin(),custom.end(),cmp);
	vector<int>window(k,28800);                        //最早八点开始上班 
	for(int i=0;i<custom.size();i++){
		int tmp=0,min_process=window[0];
		for(int j=1;j<k;j++){//对于每一个排好序的顾客,要找到最早可以为他服务的窗口,也就是最早结束工作的窗口 
			if(min_process>window[j]){
				min_process=window[j];
				tmp=j;
			} 
		}
		if(window[tmp]<=custom[i].come){
			window[tmp]=custom[i].come+custom[i].process_time;
		}
		else{
			wait+=(window[tmp]-custom[i].come);
			window[tmp]+=custom[i].process_time;
		}
	}
	printf("%.1f",wait/custom.size()/60.0);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值