PAT - 甲级 - 1017. Queueing at Bank (25)(模拟+排序)

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

给定条件:
1.n个顾客,k个窗口
2.n个顾客的到达时间和要占用窗口的时间

要求:
1.客户的平均等待时间

注意:
1.在17点之后达到的客户不在提供服务并且不计算到平均等待时间中,言外之意就是只要在17点之前就服务

求解:
1.把时间都简化成秒,方便操作
2.将客户按照到达先后排序
3.依次将每个客户安排到最早能空闲的窗口
4.更新窗口的空闲时间


#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

struct People {
	int arrive;
	int process;
} p;

bool cmp(People p1, People p2) {
	return p1.arrive < p2.arrive;
}

vector<People> v;

int n, k;
int open = 8 * 3600;
int close = 17 * 3600;
int waitt[101], sumtime = 0;

void  arrage(People p) {
	int id, latest = 999999999;
	for(int i = 0; i < k; i++) {
		if(waitt[i] < latest) {
			latest = waitt[i];
			id = i;
		}
	}
	if(p.arrive < latest) {
		sumtime += (latest - p.arrive);
		waitt[id] += p.process;
	} else {
		waitt[id] = p.arrive + p.process;
	}
}


int main() {
	scanf("%d%d", &n, &k);

	for(int i = 0; i < k; i++) {
		waitt[i] = open;
	}
	int h, m, s, time;
	for(int i = 0; i < n; i++) {
		scanf("%d:%d:%d%d", &h, &m, &s, &time);
		if(time > 60) time = 60;
		p.arrive = h * 3600 + m * 60 + s;
		p.process = time * 60;
		if(p.arrive <= close) {
			v.push_back(p);
		}
	}

	sort(v.begin(), v.end(), cmp);

	for(int i = 0; i < v.size(); i++) {
		arrage(v[i]);
	}

	if(v.size() == 0) {
		printf("0.0\n");
	} else{
		double ans = (1.0*sumtime) / (1.0*cnt);
		printf("%.1f\n", ans / 60);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值