1007 Maximum Subsequence Sum(在线处理)

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题意:求最大子列和,输出最大的子列和,子列的第一项,子列的最后一项;若序列全为负数,输出0,序列第一项,序列最后一项。

在在线处理求最大子列和的基础上记录最大子列和的首尾两个位置。

代码:

#include<iostream>
using namespace std;
int a[10005];
int main() {
	int N;
	cin>>N;
	for (int i = 0; i < N; i++) {
		cin>>a[i];
	}
	//sum为子列和,MAX为最大子列和,first记录子列和的第一项,src为最大子列和的第一项,end为最大子列和的最后一项
	int sum=0,first=0,src=N-1,end=N-1,max=-1;
	for (int i=0; i<N; i++) {
		sum+=a[i];
		//当前子列和>最大子列和时修改MAX,即SUM>MAX时,将max = sum.
		if (sum>max) {
			max=sum;
			src=first;
			end=i;
		}
		//sum<0时重置sum,first
		if(sum <0) {
			first=i+1;
			sum=0;
		}
	}
	if (max<0) cout<<0<<' '<<a[0]<<' '<<a[N-1];
	else cout <<max<<' '<<a[src]<<' '<<a[end];
	return 0;
}

 

//在线处理求序列的最大子列和
#include<iostream>
#include<cstdio>
using namespace std;
int k[100005];
int SumMax(int a[],int n){
int maxsum=0,thissum=0;
for(int i=0;i<n;i++){
thissum+=a[i];
if(thissum>maxsum)
maxsum=thissum;
else if(thissum<0)
thissum=0;
}
return maxsum;
} 
int main(){
int n;
cin>>n;
for(int i=0;i<n;i++){
scanf("%d",&k[i]);
}
int max=SumMax(k,n);
printf("%d",max);
return 0;
}

 

评论 9
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值